summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-12-10 01:14:34 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-12-10 01:14:34 +0000
commit897e7f3ab71ce18067b173fa9b3c27e6d078f0cd (patch)
tree3a73f5c21ccbc9f9da4c03c75fa5e2680eec196c /kde-base/kdebindings
parentneta beta version (diff)
downloadhistorical-897e7f3ab71ce18067b173fa9b3c27e6d078f0cd.tar.gz
historical-897e7f3ab71ce18067b173fa9b3c27e6d078f0cd.tar.bz2
historical-897e7f3ab71ce18067b173fa9b3c27e6d078f0cd.zip
neta beta version
Diffstat (limited to 'kde-base/kdebindings')
-rw-r--r--kde-base/kdebindings/Manifest4
-rw-r--r--kde-base/kdebindings/files/digest-kdebindings-3.2.0_beta21
-rw-r--r--kde-base/kdebindings/kdebindings-3.2.0_beta2.ebuild56
3 files changed, 59 insertions, 2 deletions
diff --git a/kde-base/kdebindings/Manifest b/kde-base/kdebindings/Manifest
index 34329bd5c9a5..80f3cd95cbc8 100644
--- a/kde-base/kdebindings/Manifest
+++ b/kde-base/kdebindings/Manifest
@@ -1,7 +1,7 @@
MD5 9102a87240278fdef09d74b3e33f1d60 kdebindings-3.1.4.ebuild 1575
MD5 aef38763e2fd59f6de5d641c78f4303d kdebindings-3.0.5b.ebuild 1152
-MD5 afdb12a235e606a0160c33b03c5081f6 kdebindings-3.2.0_beta2.ebuild 1540
-MD5 e26f4c4924c97f0cc289c28be8a6d715 ChangeLog 6058
+MD5 cda83c5d7b0296c0ab48da2fecc36b1f kdebindings-3.2.0_beta2.ebuild 1629
+MD5 c42f1a1227e104e902f7233ba1cf09a9 ChangeLog 6193
MD5 14889ab75f97d76e58b0c1154e7683a9 metadata.xml 161
MD5 258aa46912c7020b1ea2534a1de494e5 kdebindings-3.0.4.ebuild 1106
MD5 d85f1bc898beffe7b141a94768b1128a kdebindings-3.1.2.ebuild 1454
diff --git a/kde-base/kdebindings/files/digest-kdebindings-3.2.0_beta2 b/kde-base/kdebindings/files/digest-kdebindings-3.2.0_beta2
new file mode 100644
index 000000000000..a4233b4304fc
--- /dev/null
+++ b/kde-base/kdebindings/files/digest-kdebindings-3.2.0_beta2
@@ -0,0 +1 @@
+MD5 3842ca3e1ba9def7fb0599b610a8f652 kdebindings-3.1.94.tar.bz2 9895675
diff --git a/kde-base/kdebindings/kdebindings-3.2.0_beta2.ebuild b/kde-base/kdebindings/kdebindings-3.2.0_beta2.ebuild
new file mode 100644
index 000000000000..f313b7898073
--- /dev/null
+++ b/kde-base/kdebindings/kdebindings-3.2.0_beta2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.2.0_beta2.ebuild,v 1.1 2003/12/10 01:14:30 caleb Exp $
+# TODO: add gnustep, objc bindings
+
+inherit kde-dist
+
+IUSE="mozilla java python ruby gtk"
+DESCRIPTION="KDE library bindings for languages other than c++"
+KEYWORDS="~x86"
+
+newdepend "=kde-base/kdebase-${PV}
+ ~kde-base/kdenetwork-${PV}
+ gtk? ( =x11-libs/gtk+-1.2* )
+ =dev-libs/glib-1.2*
+ python? ( dev-lang/python )
+ java? ( virtual/jdk )
+ ruby? ( dev-lang/ruby )
+ mozilla? ( net-www/mozilla )"
+
+use python || myconf="$myconf --without-python"
+use java && myconf="$myconf --with-java=`java-config --jdk-home`" || myconf="$myconf --without-java"
+use ruby || myconf="$myconf --without-ruby"
+
+# obj bindings are officially broken
+#myconf="$myconf --enable-objc"
+
+# we need to have csant (from pnet, from portable.NET) in portage for qtsharp
+export DO_NOT_COMPILE="$DO_NOT_COMPILE qtsharp"
+
+export LIBPYTHON="`python-config`"
+
+# fix bug #14756 fex. Doesn't compile well with -j2.
+export MAKEOPTS="$MAKEOPTS -j1"
+
+src_unpack()
+{
+ kde_src_unpack
+
+ if [ -z "`use mozilla`" ]; then
+ # disable mozilla bindings/xpart, because configure doesn't seem to do so
+ # even when it doesn't detect the mozilla headers
+ cd ${S}/xparts
+ cp Makefile.am Makefile.am.orig
+ sed -e 's:mozilla::' Makefile.am.orig > Makefile.am
+ fi
+
+# # qt 3.2.1 fix, bug #29095
+# cd ${S}/smoke/qt
+# epatch ${FILESDIR}/x_QFont.cpp.diff
+# epatch ${FILESDIR}/x_QHBox.cpp.diff
+# epatch ${FILESDIR}/x_Qt.cpp.diff
+
+ cd ${S} && aclocal
+}
+