summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2004-11-12 12:51:40 +0000
committerDan Armak <danarmak@gentoo.org>2004-11-12 12:51:40 +0000
commit4fc228bdc3d6b1d072e4f5aba774ad7fb3ad50ea (patch)
treeb3546f9157fe791d9a6c38c42b8da3e103ec3129 /kde-base/kdejava/kdejava-3.3.1.ebuild
parentnew version (diff)
downloadhistorical-4fc228bdc3d6b1d072e4f5aba774ad7fb3ad50ea.tar.gz
historical-4fc228bdc3d6b1d072e4f5aba774ad7fb3ad50ea.tar.bz2
historical-4fc228bdc3d6b1d072e4f5aba774ad7fb3ad50ea.zip
Don't run java-config in the global section of the ebuild
Diffstat (limited to 'kde-base/kdejava/kdejava-3.3.1.ebuild')
-rw-r--r--kde-base/kdejava/kdejava-3.3.1.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/kde-base/kdejava/kdejava-3.3.1.ebuild b/kde-base/kdejava/kdejava-3.3.1.ebuild
index 1610651f2452..4c9c0bb136a9 100644
--- a/kde-base/kdejava/kdejava-3.3.1.ebuild
+++ b/kde-base/kdejava/kdejava-3.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdejava/kdejava-3.3.1.ebuild,v 1.2 2004/11/07 02:58:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdejava/kdejava-3.3.1.ebuild,v 1.3 2004/11/12 12:51:40 danarmak Exp $
KMNAME=kdebindings
KMEXTRACTONLY=qtjava
@@ -16,7 +16,6 @@ DEPEND="$COMMONDEPEND virtual/jdk"
RDEPEND="$COMMONDPEND virtual/jre"
PATCHES="$FILESDIR/no-gtk-glib-check.diff $FILESDIR/classpath.diff"
-myconf="$myconf --with-java=`java-config --jdk-home`"
# Probably missing other kdebase, kdepim etc deps
# Needs to be compiled with just kdelibs installed to make sure
@@ -24,13 +23,18 @@ myconf="$myconf --with-java=`java-config --jdk-home`"
# Someone who knows about java-in-gentoo should look at this and the
# other java kdebindings, and fix the stupid thing
src_unpack() {
- kde-meta_src_unpack
+ kde-meta_src_unpack
+
+ # $PREFIX-dependant, so don't go into the makefile tarballs
+ cd $S/kdejava/koala/org/kde/koala
+ for x in Makefile.am Makefile.in; do
+ mv $x $x.orig
+ sed -e "s:_CLASSPATH_:$(java-config -p qtjava):" $x.orig > $x
+ rm $x.orig
+ done
+}
- # $PREFIX-dependant, so don't go into the makefile tarballs
- cd $S/kdejava/koala/org/kde/koala
- for x in Makefile.am Makefile.in; do
- mv $x $x.orig
- sed -e "s:_CLASSPATH_:$(java-config -p qtjava):" $x.orig > $x
- rm $x.orig
- done
+src_compile() {
+ myconf="$myconf --with-java=`java-config --jdk-home`"
+ kde-meta_src_compile
}