summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 21:50:30 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 21:50:30 +0000
commitd56a49ac6fdf2ce7ddacc2a7acd2dff576228ebd (patch)
tree0e95f89e243b104e1a29dba27aede4970eb7c530 /kde-base/kmail/kmail-4.4.3.ebuild
parentUSE minimal controls now headers wrt #315567. Scribus is no reverse depend of... (diff)
downloadhistorical-d56a49ac6fdf2ce7ddacc2a7acd2dff576228ebd.tar.gz
historical-d56a49ac6fdf2ce7ddacc2a7acd2dff576228ebd.tar.bz2
historical-d56a49ac6fdf2ce7ddacc2a7acd2dff576228ebd.zip
Version bump KDE 4.4.3
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kmail/kmail-4.4.3.ebuild')
-rw-r--r--kde-base/kmail/kmail-4.4.3.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/kde-base/kmail/kmail-4.4.3.ebuild b/kde-base/kmail/kmail-4.4.3.ebuild
new file mode 100644
index 000000000000..77eae806def6
--- /dev/null
+++ b/kde-base/kmail/kmail-4.4.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.4.3.ebuild,v 1.1 2010/05/03 20:59:57 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="ayatana debug +handbook"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop')
+ $(add_kdebase_dep kdepimlibs 'akonadi')
+ $(add_kdebase_dep libkdepim)
+ $(add_kdebase_dep libkleo)
+ $(add_kdebase_dep libkpgp)
+ ayatana? ( >=dev-libs/libindicate-qt-0.2.1 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+add_blocker kmailcvt
+add_blocker libksieve
+add_blocker messagecore
+add_blocker messagelist
+add_blocker messageviewer
+add_blocker mimelib
+
+KMEXTRACTONLY="
+ korganizer/org.kde.Korganizer.Calendar.xml
+ libkleo/
+ libkpgp/
+"
+KMEXTRA="
+ kmailcvt/
+ ksendemail/
+ libksieve/
+ messagecore/
+ messagelist/
+ messageviewer/
+ mimelib/
+ plugins/kmail/
+"
+KMLOADLIBS="libkdepim"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with ayatana IndicateQt)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ # Bug #276377: kontact/ can build before kmail/, causing a dependency not to be built
+ # Upstream as KDE Bug #198807
+ # (setting MAKEOPTS to trigger a repoman warning)
+ : || MAKEOPTS="-j1"
+ kde4-meta_src_compile kmail_xml
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+ if ! has_version kde-base/kleopatra:${SLOT}; then
+ echo
+ elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
+ echo
+ fi
+}