summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-10-20 00:00:37 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-10-20 00:00:37 +0000
commit6956f78ffe03ad38ca9fc672ab1b983dd8071ee5 (patch)
treec8c8fdb5e0506fadb5ceae32d57ead0b07c77f6f /kde-base/korundum
parentVersion bump, bug #195981 (diff)
downloadhistorical-6956f78ffe03ad38ca9fc672ab1b983dd8071ee5.tar.gz
historical-6956f78ffe03ad38ca9fc672ab1b983dd8071ee5.tar.bz2
historical-6956f78ffe03ad38ca9fc672ab1b983dd8071ee5.zip
Bump to KDE 3.5.8.
Package-Manager: portage-2.1.3.15
Diffstat (limited to 'kde-base/korundum')
-rw-r--r--kde-base/korundum/ChangeLog8
-rw-r--r--kde-base/korundum/files/digest-korundum-3.5.83
-rw-r--r--kde-base/korundum/korundum-3.5.8.ebuild34
3 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/korundum/ChangeLog b/kde-base/korundum/ChangeLog
index b330765b0cd3..77fcd0f6a48f 100644
--- a/kde-base/korundum/ChangeLog
+++ b/kde-base/korundum/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/korundum
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.63 2007/08/11 17:31:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.64 2007/10/19 23:20:50 philantrop Exp $
+
+*korundum-3.5.8 (19 Oct 2007)
+
+ 19 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +korundum-3.5.8.ebuild:
+ Bump to KDE 3.5.8.
11 Aug 2007; Raúl Porcel <armin76@gentoo.org> korundum-3.5.7.ebuild:
x86 stable wrt #176297
diff --git a/kde-base/korundum/files/digest-korundum-3.5.8 b/kde-base/korundum/files/digest-korundum-3.5.8
new file mode 100644
index 000000000000..4968662d1c8f
--- /dev/null
+++ b/kde-base/korundum/files/digest-korundum-3.5.8
@@ -0,0 +1,3 @@
+MD5 b5980331e09c34dcea64297046746cc3 kdebindings-3.5.8.tar.bz2 3492800
+RMD160 dfab98ca8d9c30344ef2732f03deea87d15a9c74 kdebindings-3.5.8.tar.bz2 3492800
+SHA256 39b8449aaf0bee81a701b0915c4d742149ef37450483cce3133c6163ea3a732c kdebindings-3.5.8.tar.bz2 3492800
diff --git a/kde-base/korundum/korundum-3.5.8.ebuild b/kde-base/korundum/korundum-3.5.8.ebuild
new file mode 100644
index 000000000000..68b185d66695
--- /dev/null
+++ b/kde-base/korundum/korundum-3.5.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-3.5.8.ebuild,v 1.1 2007/10/19 23:20:50 philantrop Exp $
+
+KMNAME=kdebindings
+KMCOPYLIB="libsmokeqt smoke/qt libsmokekde smoke/kde"
+KMCOMPILEONLY="qtruby"
+KM_MAKEFILESREV=1
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE ruby bindings"
+HOMEPAGE="http://developer.kde.org/language-bindings/ruby/"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+OLDDEPEND=">=virtual/ruby-1.8 ~kde-base/qtruby-$PV ~kde-base/smoke-3.3.1"
+DEPEND=" >=virtual/ruby-1.8
+$(deprange $PV $MAXKDEVER kde-base/qtruby)
+$(deprange 3.5.6 $MAXKDEVER kde-base/smoke)"
+RDEPEND="${DEPEND}"
+
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+# Because this installs into /usr/lib/ruby/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely.
+# Note that it still depends on a specific range of (slotted) smoke and qtruby versions.
+SLOT="0"
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}