summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:28:17 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:28:17 +0000
commitdb98d8c92e9516407ef0ac404f6dc3875b62ccfb (patch)
tree0961bdd10b633d8f5e83b51631ad418927548459 /kde-base/kttsd
parentAdded the KDE 4.0.5 version of ktraderclient. (diff)
downloadhistorical-db98d8c92e9516407ef0ac404f6dc3875b62ccfb.tar.gz
historical-db98d8c92e9516407ef0ac404f6dc3875b62ccfb.tar.bz2
historical-db98d8c92e9516407ef0ac404f6dc3875b62ccfb.zip
Added the KDE 4.0.5 version of kttsd.
Package-Manager: portage-2.2_pre7/cvs/Linux 2.6.25-gentoo-r4 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Diffstat (limited to 'kde-base/kttsd')
-rw-r--r--kde-base/kttsd/ChangeLog7
-rw-r--r--kde-base/kttsd/kttsd-4.0.5.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/kde-base/kttsd/ChangeLog b/kde-base/kttsd/ChangeLog
index 2e43425a09e3..4f109b91b465 100644
--- a/kde-base/kttsd/ChangeLog
+++ b/kde-base/kttsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kttsd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.97 2008/05/18 21:41:56 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.98 2008/06/05 22:28:17 keytoaster Exp $
+
+*kttsd-4.0.5 (05 Jun 2008)
+
+ 05 Jun 2008; Tobias Heinlein <keytoaster@gentoo.org> +kttsd-4.0.5.ebuild:
+ Added the KDE 4.0.5 version of kttsd.
18 May 2008; Markus Meier <maekke@gentoo.org> kttsd-3.5.9.ebuild:
amd64/x86 stable, bug #221063
diff --git a/kde-base/kttsd/kttsd-4.0.5.ebuild b/kde-base/kttsd/kttsd-4.0.5.ebuild
new file mode 100644
index 000000000000..75761336ad74
--- /dev/null
+++ b/kde-base/kttsd/kttsd-4.0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/kttsd-4.0.5.ebuild,v 1.1 2008/06/05 22:28:17 keytoaster Exp $
+
+EAPI="1"
+
+KMNAME=kdeaccessibility
+inherit kde4-meta
+
+DESCRIPTION="KDE text-to-speech subsystem"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug htmlhandbook ktts"
+
+COMMONDEPEND="ktts? ( alsa? ( >=media-libs/alsa-lib-1.0.14a ) )
+ >=kde-base/kcmshell-${PV}:${SLOT}
+ >=kde-base/knotify-${PV}:${SLOT}"
+DEPEND="${DEPEND} ${COMMONDEPEND}"
+RDEPEND="${RDEPEND} ${COMMONDEPEND}
+ ktts? ( app-accessibility/festival
+ app-accessibility/epos
+ app-accessibility/freetts )
+ app-accessibility/flite"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with alsa Alsa)
+ -DKDE4_KTTSD_PHONON=$(use alsa && echo ON || echo OFF)
+ -DKDE4_KTTSD_ALSA=$(use alsa && echo ON || echo OFF)
+ $(cmake-utils_use_with ktts Kttsmodule)"
+
+ kde4-meta_src_compile
+}