summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2003-02-04 19:26:01 +0000
committerHannes Mehnert <hannes@gentoo.org>2003-02-04 19:26:01 +0000
commitce96063ee6aa8475929145b621b4d767d801f99b (patch)
tree82b67848541e5ad1c39bf5df03b007de1946f88d /kde-base
parentadded ~ppc (diff)
downloadhistorical-ce96063ee6aa8475929145b621b4d767d801f99b.tar.gz
historical-ce96063ee6aa8475929145b621b4d767d801f99b.tar.bz2
historical-ce96063ee6aa8475929145b621b4d767d801f99b.zip
revision bump, added 2 patches, see ChangeLog for more details
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdelibs/ChangeLog7
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.1-r21
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.1-bookmark.diff29
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.1-zip.diff61
-rw-r--r--kde-base/kdelibs/kdelibs-3.1-r2.ebuild78
5 files changed, 175 insertions, 1 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index e434879014a4..f2958e2b742d 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.48 2003/02/01 20:30:58 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.49 2003/02/04 19:26:01 hannes Exp $
+
+*kdelibs-3.1-r2 (04 Feb 2003)
+
+ 04 Feb 2003; Hannes Mehnert <hannes@gentoo.org> kdelibs-3.1-r2.ebuild:
+ should fix bug #14759 and bug #14780.
01 Feb 2003; Jack Morgan <jmorgan@gentoo.org> kdelibs-3.1.ebuild:
added ~sparc to keywords
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.1-r2 b/kde-base/kdelibs/files/digest-kdelibs-3.1-r2
new file mode 100644
index 000000000000..5e6b6600e866
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.1-r2
@@ -0,0 +1 @@
+MD5 4b5cb94d5889134ba4e86749e6b5476c kdelibs-3.1.tar.bz2 10377330
diff --git a/kde-base/kdelibs/files/kdelibs-3.1-bookmark.diff b/kde-base/kdelibs/files/kdelibs-3.1-bookmark.diff
new file mode 100644
index 000000000000..84a730bef1c1
--- /dev/null
+++ b/kde-base/kdelibs/files/kdelibs-3.1-bookmark.diff
@@ -0,0 +1,29 @@
+--- kio/bookmarks/kbookmarkmenu.cc~ 2003-02-03 16:41:06.000000000 +0100
++++ kio/bookmarks/kbookmarkmenu.cc 2003-02-03 16:44:46.000000000 +0100
+@@ -269,10 +269,10 @@
+ else
+ {
+ // kdDebug(1203) << "Creating URL bookmark menu item for " << bm.text() << endl;
+- // create a normal URL item, with ID as a name
++ // create a normal URL item, with address as a name
+ KAction * action = new KAction( text, bm.icon(), 0,
+ this, SLOT( slotBookmarkSelected() ),
+- m_actionCollection, bm.url().url().utf8() );
++ m_actionCollection, bm.address().utf8() );
+
+ action->setStatusText( bm.url().prettyURL() );
+
+@@ -369,8 +369,11 @@
+ if ( !m_pOwner ) return; // this view doesn't handle bookmarks...
+ //kdDebug(1203) << sender()->name() << endl;
+
+- // The name of the action is the URL to open
+- m_pOwner->openBookmarkURL( QString::fromUtf8(sender()->name()) );
++ KBookmark bookmark = m_pManager->findByAddress( QString::fromUtf8(sender()->name()) );
++ Q_ASSERT(!bookmark.isNull());
++ Q_ASSERT(!bookmark.isGroup());
++
++ m_pOwner->openBookmarkURL( bookmark.url().url() );
+ }
+
+ // -----------------------------------------------------------------------------
diff --git a/kde-base/kdelibs/files/kdelibs-3.1-zip.diff b/kde-base/kdelibs/files/kdelibs-3.1-zip.diff
new file mode 100644
index 000000000000..e63c14fd79ae
--- /dev/null
+++ b/kde-base/kdelibs/files/kdelibs-3.1-zip.diff
@@ -0,0 +1,61 @@
+diff -u -r kio/kio/kzip.cpp kio/kio/kzip.cpp
+--- kio/kio/kzip.cpp 2003-01-03 02:58:47.000000000 -0200
++++ kio/kio/kzip.cpp 2003-01-29 22:16:15.000000000 -0200
+@@ -332,27 +332,43 @@
+
+ KArchiveEntry* entry;
+ if ( isdir )
+- entry = new KArchiveDirectory( this, entryName, access, time, rootDir()->user(), rootDir()->group(), QString::null );
++ {
++ QString path = QDir::cleanDirPath( name.left( pos ) );
++ KArchiveEntry* ent = rootDir()->entry( path );
++ if ( ent && ent->isDirectory() )
++ {
++ //kdDebug(7040) << "Directory already exists, NOT going to add it again" << endl;
++ entry = 0L;
++ }
++ else
++ {
++ entry = new KArchiveDirectory( this, entryName, access, time, rootDir()->user(), rootDir()->group(), QString::null );
++ //kdDebug(7040) << "KArchiveDirectory created, entryName= " << entryName << ", name=" << name << endl;
++ }
++ }
+ else
+ {
+ entry = new KZipFileEntry( this, entryName, access, time, rootDir()->user(), rootDir()->group(), QString::null,
+- name, dataoffset, ucsize, cmethod, csize );
++ name, dataoffset, ucsize, cmethod, csize );
+ static_cast<KZipFileEntry *>(entry)->setHeaderStart( localheaderoffset );
+- //kdDebug(7040) << "KZipFileEntry created" << endl;
++ //kdDebug(7040) << "KZipFileEntry created, entryName= " << entryName << ", name=" << name << endl;
+ d->m_fileList.append( static_cast<KZipFileEntry *>( entry ) );
+ }
+
+- if ( pos == -1 )
+- {
+- rootDir()->addEntry(entry);
+- }
+- else
+- {
+- // In some tar files we can find dir/./file => call cleanDirPath
+- QString path = QDir::cleanDirPath( name.left( pos ) );
+- // Ensure container directory exists, create otherwise
+- KArchiveDirectory * tdir = findOrCreate( path );
+- tdir->addEntry(entry);
++ if ( entry )
++ {
++ if ( pos == -1 )
++ {
++ rootDir()->addEntry(entry);
++ }
++ else
++ {
++ // In some tar files we can find dir/./file => call cleanDirPath
++ QString path = QDir::cleanDirPath( name.left( pos ) );
++ // Ensure container directory exists, create otherwise
++ KArchiveDirectory * tdir = findOrCreate( path );
++ tdir->addEntry(entry);
++ }
+ }
+
+ //calculate offset to next entry
diff --git a/kde-base/kdelibs/kdelibs-3.1-r2.ebuild b/kde-base/kdelibs/kdelibs-3.1-r2.ebuild
new file mode 100644
index 000000000000..c196cd021380
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.1-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1-r2.ebuild,v 1.1 2003/02/04 19:26:01 hannes Exp $
+
+inherit kde kde.org
+#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+IUSE="alsa cups ipv6 ssl"
+DESCRIPTION="KDE libraries needed by all kde programs"
+KEYWORDS="~x86 ~ppc"
+HOMEPAGE="http//www.kde.org/"
+SLOT="3.1"
+LICENSE="GPL-2 LGPL-2"
+
+PATCHES="${FILESDIR}/${P}-bookmark.diff
+ ${FILESDIR}/${P}-zip.diff"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
+# so we recreate the entire DEPEND from scratch.
+DEPEND=""
+RDEPEND=""
+newdepend "sys-devel/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 >=media-sound/alsa-driver-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ ~kde-base/arts-1.1.0
+ app-text/ghostscript"
+
+newdepend "/c"
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python
+ >=sys-apps/portage-2.0.36" # for #7359
+
+myconf="$myconf --with-distribution=Gentoo --enable-libfam --enable-dnotify"
+use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+use x86 && myconf="$myconf --enable-fast-malloc=full"
+use alpha && append-flags -mieee
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+src_unpack() {
+ kde_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+}
+
+src_install() {
+
+ kde_src_install
+
+ dohtml *.html
+
+ dodir /etc/env.d
+
+echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${PREFIX}/lib
+CONFIG_PROTECT=${PREFIX}/share/config" > ${D}/etc/env.d/49kdelibs-${PV} # number goes down with version upgrade
+
+ echo "KDEDIR=$PREFIX" > ${D}/etc/env.d/56kdedir-${PV} # number goes up with version upgrade
+}