summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-10-09 06:57:41 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-10-09 06:57:41 +0000
commitdaa088bb613b127ed84ca589ff3badf8b22aab31 (patch)
treef89d84c3af15274e702d75f389243a69f44f28ed /kde-misc/magneto-kde
parentversion bump (diff)
downloadhistorical-daa088bb613b127ed84ca589ff3badf8b22aab31.tar.gz
historical-daa088bb613b127ed84ca589ff3badf8b22aab31.tar.bz2
historical-daa088bb613b127ed84ca589ff3badf8b22aab31.zip
version bump
Package-Manager: portage-2.2.0_alpha51/cvs/Linux x86_64
Diffstat (limited to 'kde-misc/magneto-kde')
-rw-r--r--kde-misc/magneto-kde/ChangeLog7
-rw-r--r--kde-misc/magneto-kde/magneto-kde-1.0_rc59.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/kde-misc/magneto-kde/ChangeLog b/kde-misc/magneto-kde/ChangeLog
index cba9c53d0a97..3c5ee9cc3395 100644
--- a/kde-misc/magneto-kde/ChangeLog
+++ b/kde-misc/magneto-kde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/magneto-kde
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/ChangeLog,v 1.12 2011/09/18 10:53:04 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/ChangeLog,v 1.13 2011/10/09 06:57:41 lxnay Exp $
+
+*magneto-kde-1.0_rc59 (09 Oct 2011)
+
+ 09 Oct 2011; Fabio Erculiani <lxnay@gentoo.org> +magneto-kde-1.0_rc59.ebuild:
+ version bump
*magneto-kde-1.0_rc53 (18 Sep 2011)
diff --git a/kde-misc/magneto-kde/magneto-kde-1.0_rc59.ebuild b/kde-misc/magneto-kde/magneto-kde-1.0_rc59.ebuild
new file mode 100644
index 000000000000..24c9c4184510
--- /dev/null
+++ b/kde-misc/magneto-kde/magneto-kde-1.0_rc59.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/magneto-kde-1.0_rc59.ebuild,v 1.1 2011/10/09 06:57:41 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python
+
+DESCRIPTION="Entropy Package Manager notification applet KDE frontend"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/magneto"
+
+RDEPEND="~app-misc/magneto-loader-${PV}
+ kde-base/pykde4
+ dev-python/PyQt4[dbus]"
+DEPEND=""
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" magneto-kde-install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/magneto/magneto/kde"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/magneto/magneto/kde"
+}