summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-12-21 17:42:37 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-12-21 17:42:37 +0000
commit51ca8863099cd6ab1405a4f887e4c1147188b7e4 (patch)
treed072c1e551b479174b2a9f90e17637b9daf1a210 /mail-client/nail
parentVersion bump. Closes bug #75205. (diff)
downloadhistorical-51ca8863099cd6ab1405a4f887e4c1147188b7e4.tar.gz
historical-51ca8863099cd6ab1405a4f887e4c1147188b7e4.tar.bz2
historical-51ca8863099cd6ab1405a4f887e4c1147188b7e4.zip
Version bump. Closes #75206.
Diffstat (limited to 'mail-client/nail')
-rw-r--r--mail-client/nail/ChangeLog7
-rw-r--r--mail-client/nail/files/digest-nail-11.181
-rw-r--r--mail-client/nail/nail-11.18.ebuild61
3 files changed, 68 insertions, 1 deletions
diff --git a/mail-client/nail/ChangeLog b/mail-client/nail/ChangeLog
index 517e95f3b916..a38604517438 100644
--- a/mail-client/nail/ChangeLog
+++ b/mail-client/nail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/nail
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/nail/ChangeLog,v 1.16 2004/12/15 12:14:58 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/nail/ChangeLog,v 1.17 2004/12/21 17:42:37 ticho Exp $
+
+*nail-11.18 (21 Dec 2004)
+
+ 21 Dec 2004; Andrej Kacian <ticho@gentoo.org> +nail-11.18.ebuild:
+ Version bump. Bug #75206, reported by Vanquirius <marcelogoes@gmail.com>.
*nail-11.1-r1 (15 Dec 2004)
diff --git a/mail-client/nail/files/digest-nail-11.18 b/mail-client/nail/files/digest-nail-11.18
new file mode 100644
index 000000000000..26a2cda7441d
--- /dev/null
+++ b/mail-client/nail/files/digest-nail-11.18
@@ -0,0 +1 @@
+MD5 89f4b8502440e1c1753e1e2f911f5a0c nail-11.18.tar.bz2 264493
diff --git a/mail-client/nail/nail-11.18.ebuild b/mail-client/nail/nail-11.18.ebuild
new file mode 100644
index 000000000000..46e2784f2d06
--- /dev/null
+++ b/mail-client/nail/nail-11.18.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/nail/nail-11.18.ebuild,v 1.1 2004/12/21 17:42:37 ticho Exp $
+
+inherit eutils
+DESCRIPTION="Nail is a mail user agent derived from Berkeley Mail 8.1 and contains builtin support for MIME messages."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://nail.sourceforge.net/"
+PROVIDE="virtual/mailx"
+DEPEND="virtual/libc
+ !virtual/mailx"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64 ~alpha ~ia64"
+IUSE=""
+
+src_compile() {
+ # ./configure no longer required
+ emake PREFIX=/usr MAILSPOOL='~/.maildir' || die "emake failed"
+}
+
+src_install () {
+ #add smtp flag to nail.rc so that it uses smtp by default (making it
+ #essentially mailer independent
+ echo -e "\n#use smtp on the local system by default. Change" >> nail.rc
+ echo -e "#\"localhost\" to your smtp server if you use a remote" >> nail.rc
+ echo -e "#smtp server. (Delete this line to use sendmail instead)" >> nail.rc
+ echo -e "set smtp=localhost" >> nail.rc
+
+ make DESTDIR=${D} UCBINSTALL=/bin/install PREFIX=/usr install || die "install failed"
+ dodoc AUTHORS COPYING I18N INSTALL README
+ dodir /bin
+ dosym /usr/bin/nail /bin/mail
+ dosym /usr/bin/nail /usr/bin/mailx
+ dosym /usr/bin/nail /usr/bin/mail
+ dosym /usr/bin/nail /usr/bin/Mail
+}
+
+pkg_postinst () {
+ echo
+ einfo "NOTE: The nail mailer does _not_ support maildir format."
+ einfo " It is best to use nail only for outgoing mail, and"
+ einfo " really only use it for scripts that require it."
+ echo
+ einfo "NOTE: This build has ~/.maildir compiled in as the"
+ einfo " mail spool directory (for incoming mail)."
+ einfo " Nail will work for sending outgoing mail even if"
+ einfo " the mail spool directory does not exist."
+ echo
+ einfo "NOTE: When used to send mail via a remote smtp server"
+ einfo " nail does not require a local mail transfer agent."
+ einfo " ISP smtp servers tend to have names like"
+ einfo " mail.ispname.com"
+ einfo " or"
+ einfo " smtp.ispname.com."
+ einfo " If you do not wish to use a remote smtp server,"
+ einfo " then you WILL have to install a mta such as sendmail,"
+ einfo " postfix, exim, etcetera."
+ echo
+}