summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-12-15 09:58:46 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-12-15 09:58:46 +0000
commit8e1b6d49a7c477ea6f3c5ca338ba54a0f6a88d15 (patch)
tree25ffc6a6ea2d597cac455eec2d30d3f433aa5511 /mail-mta/nbsmtp/nbsmtp-0.97.ebuild
parentinitial commit - ebuild submitted by eGore via bug #66503 (diff)
downloadhistorical-8e1b6d49a7c477ea6f3c5ca338ba54a0f6a88d15.tar.gz
historical-8e1b6d49a7c477ea6f3c5ca338ba54a0f6a88d15.tar.bz2
historical-8e1b6d49a7c477ea6f3c5ca338ba54a0f6a88d15.zip
Version bump. Closes #74340.
Diffstat (limited to 'mail-mta/nbsmtp/nbsmtp-0.97.ebuild')
-rw-r--r--mail-mta/nbsmtp/nbsmtp-0.97.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/mail-mta/nbsmtp/nbsmtp-0.97.ebuild b/mail-mta/nbsmtp/nbsmtp-0.97.ebuild
new file mode 100644
index 000000000000..1c2f6a909516
--- /dev/null
+++ b/mail-mta/nbsmtp/nbsmtp-0.97.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nbsmtp/nbsmtp-0.97.ebuild,v 1.1 2004/12/15 09:58:46 ticho Exp $
+
+DESCRIPTION="Extremely simple MTA to get mail off the system to a relayhost"
+SRC_URI="http://www.gentoo-es.org/~ferdy/${P}.tar.bz2"
+HOMEPAGE="http://nbsmtp.ferdyx.org"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~hppa ~amd64 ~sparc"
+LICENSE="GPL-2"
+IUSE="ssl ipv6 debug"
+
+DEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )"
+
+PROVIDE="virtual/mta"
+
+src_compile() {
+ local myconf
+
+ use ipv6 && myconf="${myconf} --enable-inet6"
+
+ econf `use_enable ssl` \
+ `use_enable debug` \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dobin nbsmtp
+ doman nbsmtprc.5 nbsmtp.8
+ dodoc INSTALL DOCS Doxyfile
+}