summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott W Taylor <swtaylor@gentoo.org>2005-01-31 00:35:56 +0000
committerScott W Taylor <swtaylor@gentoo.org>2005-01-31 00:35:56 +0000
commit31293466ceae1d25a0f619c3749334390d441f42 (patch)
tree12f94e86d388ef0a7b56d82b304c2518c1d75e52 /mail-mta
parentrepoman: Fix leading whitespace (diff)
downloadhistorical-31293466ceae1d25a0f619c3749334390d441f42.tar.gz
historical-31293466ceae1d25a0f619c3749334390d441f42.tar.bz2
historical-31293466ceae1d25a0f619c3749334390d441f42.zip
bump and add smtp auth
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/courier/ChangeLog6
-rw-r--r--mail-mta/courier/Manifest4
-rw-r--r--mail-mta/courier/courier-0.48.2.20050130.ebuild16
3 files changed, 15 insertions, 11 deletions
diff --git a/mail-mta/courier/ChangeLog b/mail-mta/courier/ChangeLog
index 4eba54c4c10d..3883f5dd9273 100644
--- a/mail-mta/courier/ChangeLog
+++ b/mail-mta/courier/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-mta/courier
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/ChangeLog,v 1.44 2005/01/30 23:33:25 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/ChangeLog,v 1.45 2005/01/31 00:35:55 swtaylor Exp $
+
+ 30 Jan 2005; Scott W Taylor <swtaylor@gentoo.org>
+ courier-0.48.2.20050130.ebuild:
+ version bump, add smtp auth methods as well.
*courier-0.48.2 (30 Jan 2005)
diff --git a/mail-mta/courier/Manifest b/mail-mta/courier/Manifest
index 5d6b981b60e9..f4051a743625 100644
--- a/mail-mta/courier/Manifest
+++ b/mail-mta/courier/Manifest
@@ -1,8 +1,8 @@
MD5 241c59b1f8572ca70f8c8e4cc921dcac courier-0.48.2.ebuild 8858
MD5 d21c8e91e2922fb10c36bdcbb71c08d8 courier-0.48.1.ebuild 8781
-MD5 cf596ba98f7d1f3ca34f0a0340bf9e35 ChangeLog 17314
+MD5 988ab93c9993b90ceab89d60d5e68895 ChangeLog 17448
MD5 b287829e2f9edbcf1ff7bb349055e77e metadata.xml 392
-MD5 7e71f49b733da3a274e3aac78de676f2 courier-0.48.2.20050130.ebuild 9124
+MD5 797bf4e8a787216626bc617713aa348e courier-0.48.2.20050130.ebuild 9331
MD5 8dc1f764de5f1ce1e3a21faac1d1b41f courier-0.47-r1.ebuild 10994
MD5 52f032e570c6f5f9f69b4e4bdfa562a1 files/password.dist 247
MD5 a546a21f960e4f921e71f614f719a2ce files/bofh 23
diff --git a/mail-mta/courier/courier-0.48.2.20050130.ebuild b/mail-mta/courier/courier-0.48.2.20050130.ebuild
index 6ecc18b68a66..946f2d56fe8e 100644
--- a/mail-mta/courier/courier-0.48.2.20050130.ebuild
+++ b/mail-mta/courier/courier-0.48.2.20050130.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.48.2.20050130.ebuild,v 1.1 2005/01/30 23:33:25 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.48.2.20050130.ebuild,v 1.2 2005/01/31 00:35:56 swtaylor Exp $
inherit eutils
@@ -14,8 +14,7 @@ S="${WORKDIR}/${P%%_pre}"
SLOT="0"
LICENSE="GPL-2"
# not in keywords due to missing dependencies: ~arm ~s390 ~ppc64
-#KEYWORDS="~x86 ~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc"
-KEYWORDS="-*"
+KEYWORDS="~x86 ~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc"
IUSE="postgres ldap mysql pam nls ipv6 spell fax crypt norewrite uclibc mailwrapper"
PROVIDE="virtual/mta
@@ -99,11 +98,10 @@ etc_courier() {
}
etc_courier_chg() {
- set -v -x
- file="${1}" ; key="${2}" ; value="${3}"
+ file="${1}" ; key="${2}" ; value="${3}" ; section="${4}"
+ [ -z "${section}" ] && section="${2}"
grep -q "${key}" "${file}" && einfo "Changing ${file}: ${key} to ${value}"
- sed -i -e"/\#\#NAME: ${key}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
- set +v +x
+ sed -i -e"/\#\#NAME: ${section}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
}
set_maildir() {
@@ -170,7 +168,9 @@ src_install() {
etc_courier esmtpd-msa "BOFHBADMIME=accept"
etc_courier_chg esmtpd ESMTPDSTART YES
etc_courier_chg esmtpd ESMTPAUTH "LOGIN CRAM-SHA1 CRAM-MD5"
- etc_courier_chg esmtpd ESMTPAUTH_TLS "PLAIN LOGIN CRAM-SHA1 CRAM-MD5"
+ etc_courier_chg esmtpd ESMTPAUTH_WEBADMIN "LOGIN CRAM-SHA1 CRAM-MD5"
+ etc_courier_chg esmtpd ESMTPAUTH_TLS "PLAIN LOGIN CRAM-SHA1 CRAM-MD5" ESMTPAUTHINFOTLS
+ etc_courier_chg esmtpd ESMTPAUTH_TLS_WEBADMIN "PLAIN LOGIN CRAM-SHA1 CRAM-MD5" ESMTPAUTHINFOTLS
etc_courier_chg esmtpd-msa ESMTPDSTART YES
etc_courier_chg esmtpd-msa AUTH_REQUIRED 1
etc_courier_chg esmtpd-ssl ESMTPDSSLSTART YES