summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-07-04 04:20:31 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-07-04 04:20:31 +0000
commitc5754a8f026d8bf35fb33e679c3bdb5a9b2dbb4f (patch)
tree72ea10130136e3cf384ed392e64bc7bf7fc73865 /media-gfx/asymptote/files
parentRemove old. (diff)
downloadhistorical-c5754a8f026d8bf35fb33e679c3bdb5a9b2dbb4f.tar.gz
historical-c5754a8f026d8bf35fb33e679c3bdb5a9b2dbb4f.tar.bz2
historical-c5754a8f026d8bf35fb33e679c3bdb5a9b2dbb4f.zip
Version bump. New USE flags. Dependence on virtual/tetex removed. Various ebuild improvements. Cleaning up old versions.
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.25-tuxonice-r1 i686
Diffstat (limited to 'media-gfx/asymptote/files')
-rw-r--r--media-gfx/asymptote/files/asymptote-1.43-configure-ac.patch43
-rw-r--r--media-gfx/asymptote/files/asymptote-1.43-xdg-utils.patch19
2 files changed, 62 insertions, 0 deletions
diff --git a/media-gfx/asymptote/files/asymptote-1.43-configure-ac.patch b/media-gfx/asymptote/files/asymptote-1.43-configure-ac.patch
new file mode 100644
index 000000000000..aa101a046317
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-1.43-configure-ac.patch
@@ -0,0 +1,43 @@
+diff -U2 --recursive asymptote-1.43.orig/configure.ac asymptote-1.43/configure.ac
+--- asymptote-1.43.orig/configure.ac 2008-06-12 14:42:50.000000000 +0700
++++ asymptote-1.43/configure.ac 2008-06-22 17:30:54.000000000 +0700
+@@ -77,8 +77,14 @@
+ fi
+
+-AC_CHECK_HEADER(fftw3.h,
+- AC_CHECK_LIB([fftw3], fftw_execute,,
++AC_ARG_WITH([fftw],
++ [ --with-fftw use fftw3],
++ [with_fftw=$withval],
++ [with_fftw="no"])
++if test "$with_fftw" = "yes"; then
++AC_CHECK_HEADER([fftw3.h],
++ AC_CHECK_LIB([fftw3], [fftw_execute],,
+ AC_MSG_NOTICE([*** Could not find libfftw3: will compile without optional fast Fourier transforms. ***])),
+ AC_MSG_NOTICE([*** Header file fftw3.h not found: will compile without optional fast Fourier transforms. ***]))
++fi
+
+ GCVERSION=gc-7.1
+@@ -117,5 +123,5 @@
+ CPPFLAGS_SAVE=$CPPFLAGS
+ CPPFLAGS=$CPPFLAGS" $INCL"
+- AC_CHECK_HEADER(gc.h,
++ AC_CHECK_HEADER([gc/gc.h],
+ AC_CHECK_LIB([gc],[GC_malloc],[
+ LIBS=$LIBS"-lgc "
+@@ -198,4 +204,9 @@
+ AC_MSG_WARN([*** Broken rpc headers; XDR support disabled ***]))
+
++AC_ARG_WITH(gsl,
++ [ --with-gsl use gsl libraries],
++ [with_gsl=$withval],
++ [with_gsl="no"])
++if test "$with_gsl" = "yes"; then
+ AC_CHECK_HEADER(gsl/gsl_sf.h,
+ AC_CHECK_LIB([gsl], gsl_sf_Si, [AC_DEFINE(HAVE_LIBGSL, 1,
+@@ -203,4 +214,5 @@
+ AC_MSG_NOTICE([*** Could not find libgsl: will compile without optional special functions. ***]),[-lgslcblas]),
+ AC_MSG_NOTICE([*** Header file gsl_sf.h not found: will compile without optional special functions. ***]))
++fi
+
+ TRIANGLE=Delaunay
diff --git a/media-gfx/asymptote/files/asymptote-1.43-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-1.43-xdg-utils.patch
new file mode 100644
index 000000000000..b21c863a2645
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-1.43-xdg-utils.patch
@@ -0,0 +1,19 @@
+diff -U2 --recursive asymptote-1.43.orig/settings.cc asymptote-1.43/settings.cc
+--- asymptote-1.43.orig/settings.cc 2008-06-12 14:41:38.000000000 +0700
++++ asymptote-1.43/settings.cc 2008-06-22 17:26:21.000000000 +0700
+@@ -75,12 +75,12 @@
+ const char *HOME="HOME";
+ const char pathSeparator=':';
+-string defaultPSViewer="gv";
++string defaultPSViewer="xdg-open";
+ #ifdef __APPLE__
+ string defaultPDFViewer="open";
+ #else
+-string defaultPDFViewer="acroread";
++string defaultPDFViewer="xdg-open";
+ #endif
+ string defaultGhostscript="gs";
+-string defaultDisplay="display";
++string defaultDisplay="xdg-open";
+ string defaultPython;
+ const string docdir=ASYMPTOTE_DOCDIR;