summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-08-18 12:07:20 +0000
committerTroy Dack <tad@gentoo.org>2003-08-18 12:07:20 +0000
commit42a724dd96eddab1b89661a2c99bbadaa8605b29 (patch)
tree412573932c0979235cf65decee9c433d1bb0a04b /media-gfx/bootsplash
parentUpdate to -r2, closes Bugs #20497, #26245, #20964. (diff)
downloadhistorical-42a724dd96eddab1b89661a2c99bbadaa8605b29.tar.gz
historical-42a724dd96eddab1b89661a2c99bbadaa8605b29.tar.bz2
historical-42a724dd96eddab1b89661a2c99bbadaa8605b29.zip
Update to -r2, closes Bugs #20497, #26245, #20964.
Diffstat (limited to 'media-gfx/bootsplash')
-rw-r--r--media-gfx/bootsplash/Manifest4
-rw-r--r--media-gfx/bootsplash/bootsplash-0.6-r2.ebuild122
-rw-r--r--media-gfx/bootsplash/files/digest-bootsplash-0.6-r21
3 files changed, 125 insertions, 2 deletions
diff --git a/media-gfx/bootsplash/Manifest b/media-gfx/bootsplash/Manifest
index b92c8034fd34..5ccc41650199 100644
--- a/media-gfx/bootsplash/Manifest
+++ b/media-gfx/bootsplash/Manifest
@@ -1,5 +1,5 @@
MD5 d3809569b6a08794ed45afd240c1876c bootsplash-0.6-r1.ebuild 3346
-MD5 217cb263200520d60b53845c888cdb25 bootsplash-0.6-r2.ebuild 3390
-MD5 ebf5cb229c0aa99b1b9d2e84c703277f ChangeLog 1327
+MD5 ef1206992f8600d10b7848ed513d9eea bootsplash-0.6-r2.ebuild 3386
+MD5 a584ff7fd56d7a4b1f500405f07893fb ChangeLog 1480
MD5 3fa4a534a7a0b0dd84e1e99c032010b8 files/digest-bootsplash-0.6-r1 67
MD5 0bf6318b85e220548699e20dbb0b9390 files/digest-bootsplash-0.6-r2 70
diff --git a/media-gfx/bootsplash/bootsplash-0.6-r2.ebuild b/media-gfx/bootsplash/bootsplash-0.6-r2.ebuild
new file mode 100644
index 000000000000..53c2a729d80f
--- /dev/null
+++ b/media-gfx/bootsplash/bootsplash-0.6-r2.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/bootsplash-0.6-r2.ebuild,v 1.1 2003/08/18 12:07:09 tad Exp $
+
+DESCRIPTION="Graphical backgrounds for frame buffer consoles"
+HOMEPAGE="http://linux.tkdack.com/"
+SRC_URI="mirror://gentoo/bootsplash-${PV}-${PR}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+S="${WORKDIR}/${PF}"
+
+DEPEND=">=media-libs/freetype-2
+ media-libs/libmng"
+
+RDEPEND=""
+
+src_compile() {
+ # compile utils
+ # the util builds but the rc scripts have not been modified
+ # animated boot up require patches to the baselayout package
+ cd ${S}/utils/fbmngplay
+ emake fbmngplay || die
+
+ cd ${S}/utils/fbtruetype
+ emake || die
+
+ cd ${S}/utils/splashutils
+ emake || die
+}
+
+src_install() {
+ # Splash utilities
+ exeinto /sbin
+ doexe ${S}/utils/fbmngplay/fbmngplay
+ doexe ${S}/utils/fbtruetype/fbtruetype
+ doexe ${S}/utils/fbtruetype/fbtruetype.static
+ doexe ${S}/utils/splashutils/splash
+ doexe ${S}/utils/splashutils/fbresolution
+ doexe ${S}/utils/splashutils/getkey
+
+ mkdir -p ${D}/etc/${PN}
+ cp -pR ${S}/themes/* ${D}/etc/${PN}
+
+ # link default config - for boot images
+ dosym ./gentoo /etc/bootsplash/default
+
+ insinto /etc/init.d
+ doins ${S}/misc/bootsplash
+ fperms 755 /etc/init.d/bootsplash
+
+ insinto /etc/conf.d
+ doins ${S}/misc/bootsplash.conf
+
+ insinto /usr/share/${PN}
+ doins ${S}/kernel/bootsplash-3.0.7-2.4.20-vanilla.diff
+ doins ${S}/misc/grub.conf.sample
+
+# dodoc README
+# dodoc COPYING
+# dodoc CREDITS
+
+}
+
+pkg_postinst() {
+ # Has to be done here so that the initrd images are created properly
+ for SIZE in 800x600 1024x768 1280x1024 1600x1200
+ do
+ /sbin/splash -s -f /etc/bootsplash/gentoo/config/bootsplash-${SIZE}.cfg > /usr/share/${PN}/initrd-${SIZE}
+ done
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/media-gfx/${PF}/${PF}.ebuild config\""
+ einfo "to have your kernel sources in /usr/src/linux patched with the"
+ einfo "Framebuffer Bootsplash patches"
+ einfo
+ echo ""
+ ewarn "If you have already patched the kernel then you only need to copy"
+ ewarn "an initrd from /usr/share/${PN} to /boot"
+ ewarn
+ echo ""
+ einfo
+ einfo "Run:"
+ einfo " rc-update add bootsplash default"
+ einfo " to change the console images after startup"
+ einfo
+}
+
+pkg_config() {
+ ewarn
+ ewarn "Patching the kernel in /usr/src/linux ..."
+ ewarn
+ cd ${ROOT}/usr/src/linux
+ patch -p1 < ${ROOT}/usr/share/${PN}/bootsplash-3.0.7-2.4.20-vanilla.diff || die
+ ewarn
+ ewarn " ... complete."
+ einfo
+ einfo "Your kernel has been patched, rebuild with the following options"
+ einfo "enabled (do not build them as modules!):"
+ einfo " Block Devices ->"
+ einfo " [*] RAM disk support"
+ einfo " [*] Loopback device support"
+ einfo " [*] Initial RAM disk (initrd) support"
+ einfo
+ einfo " Console Drivers ->"
+ einfo " [*] Video mode selection support"
+ einfo " Frame-buffer support ->"
+ einfo " [*] Support for frame buffer devices"
+ einfo " [*] VESA VGA graphics console"
+ einfo " [*] Use splash screen instead of boot logo"
+ einfo
+ einfo "Copy an initrd from /usr/share/${PN} to /boot"
+ einfo
+ einfo "Look at \"/usr/share/${PN}/grub.conf.sample\" for an example"
+ einfo "grub.conf file with the appropriate changes to enable the"
+ einfo "framebuffer boot screens"
+ einfo
+ einfo "Ensure you make the appropriate changes to your grub.conf"
+ einfo
+}
diff --git a/media-gfx/bootsplash/files/digest-bootsplash-0.6-r2 b/media-gfx/bootsplash/files/digest-bootsplash-0.6-r2
new file mode 100644
index 000000000000..259f35ba6143
--- /dev/null
+++ b/media-gfx/bootsplash/files/digest-bootsplash-0.6-r2
@@ -0,0 +1 @@
+MD5 fc36788fbcf309017e82dd8ebf607c8a bootsplash-0.6-r2.tar.bz2 308660