summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-06-29 18:32:13 +0000
committerMichael Januszewski <spock@gentoo.org>2004-06-29 18:32:13 +0000
commit48d5f43600fb8b2e65e81d81a7d16a23f971c603 (patch)
tree575db76a09ca272905229bc4eaca1fb590945b44 /media-gfx/bootsplash
parentsync IUSE (+3ds, +freetype, +mikmod, +mng, +oggvorbis, +openal, +zlib) (diff)
downloadhistorical-48d5f43600fb8b2e65e81d81a7d16a23f971c603.tar.gz
historical-48d5f43600fb8b2e65e81d81a7d16a23f971c603.tar.bz2
historical-48d5f43600fb8b2e65e81d81a7d16a23f971c603.zip
Fixed 24bpp mode problems, added support for 15bpp and DIRECTCOLOR modes.
Diffstat (limited to 'media-gfx/bootsplash')
-rw-r--r--media-gfx/bootsplash/ChangeLog9
-rw-r--r--media-gfx/bootsplash/Manifest4
-rw-r--r--media-gfx/bootsplash/bootsplash-0.6.1-r3.ebuild99
-rw-r--r--media-gfx/bootsplash/files/digest-bootsplash-0.6.1-r33
4 files changed, 113 insertions, 2 deletions
diff --git a/media-gfx/bootsplash/ChangeLog b/media-gfx/bootsplash/ChangeLog
index e729a699377d..c51725abd91d 100644
--- a/media-gfx/bootsplash/ChangeLog
+++ b/media-gfx/bootsplash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/bootsplash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.46 2004/06/26 13:02:35 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.47 2004/06/29 18:32:13 spock Exp $
+
+*bootsplash-0.6.1-r3 (29 Jun 2004)
+
+ 29 Jun 2004; Michal Januszewski <spock@gentoo.org>
+ +bootsplash-0.6.1-r3.ebuild:
+ Fixed 24bpp mode problems, added support for 15bpp and DIRECTCOLOR modes.
+ Radeonfb users should be happy now :)
*bootsplash-0.6.1-r2 (26 Jun 2004)
diff --git a/media-gfx/bootsplash/Manifest b/media-gfx/bootsplash/Manifest
index 15bbc8774d14..b89c79ffa39b 100644
--- a/media-gfx/bootsplash/Manifest
+++ b/media-gfx/bootsplash/Manifest
@@ -1,10 +1,12 @@
+MD5 ab1cfbace79b0d784547499d6b5af96c bootsplash-0.6.1-r3.ebuild 2929
MD5 35215cba6931c8aafc66f3a0056d79bd bootsplash-0.6-r16.ebuild 6676
MD5 57f9bb5cffc33449dba93ae3ee0684dd bootsplash-0.6.1-r2.ebuild 2929
MD5 e379e8b97771fec47e39126c46f2a23a bootsplash-0.6.1.ebuild 2977
-MD5 00e2a120fc042961f509fa6762666e13 ChangeLog 9452
+MD5 11e4f791b536adfb07c68f41dd5f22d1 ChangeLog 9689
MD5 d94d306da3804e41296e1bf04c7c9cae metadata.xml 255
MD5 6b3fad22b3df80e38f526c716975d3f2 bootsplash-0.6.1-r1.ebuild 2932
MD5 fefac2c788a3be2229bdc9c14f005f97 files/digest-bootsplash-0.6.1-r1 232
MD5 df9460bab7fb08520b7b60dc2ac6b208 files/digest-bootsplash-0.6.1-r2 232
+MD5 13ff4624d1f05d685afc44f98853ca03 files/digest-bootsplash-0.6.1-r3 232
MD5 726928711fd5cbfa499b4ede2ed722a8 files/digest-bootsplash-0.6.1 226
MD5 e07733044709e48e34df036d69dc9f3a files/digest-bootsplash-0.6-r16 71
diff --git a/media-gfx/bootsplash/bootsplash-0.6.1-r3.ebuild b/media-gfx/bootsplash/bootsplash-0.6.1-r3.ebuild
new file mode 100644
index 000000000000..e6529482aac4
--- /dev/null
+++ b/media-gfx/bootsplash/bootsplash-0.6.1-r3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/bootsplash-0.6.1-r3.ebuild,v 1.1 2004/06/29 18:32:13 spock Exp $
+
+IUSE=""
+S=${WORKDIR}
+DESCRIPTION="Graphical backgrounds for frame buffer consoles"
+HOMEPAGE="http://www.bootsplash.org/ http://linux.tkdack.com/"
+SRC_URI="http://dev.gentoo.org/~spock/portage/distfiles/${PN}-core-0.6.1-r3.tar.bz2
+ http://dev.gentoo.org/~spock/portage/distfiles/${PN}-themes-0.6.1.tar.bz2
+ http://dev.gentoo.org/~spock/portage/distfiles/${PN}-kernel-0.6.1-r3.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=">=media-libs/freetype-2
+ media-libs/libmng"
+
+src_compile() {
+ # compile utils
+ # the util builds but the rc scripts have not been modified
+ # animated boot up require patches to the baselayout package
+ cd ${S}/utils
+
+ emake -C fbmngplay || die
+ emake -C fbtruetype || die
+ emake -C splashutils || die
+
+ cd ${S}
+}
+
+src_install() {
+ # Splash utilities
+ exeinto /sbin
+ doexe utils/fbmngplay/fbmngplay{,.static}
+ doexe utils/fbtruetype/fbtruetype{,.static}
+ doexe misc/bootsplash_resize
+ newexe utils/splashutils/splash splash.bin
+ doexe misc/splash
+ doexe utils/splashutils/{fbresolution,getkey,progress}
+
+ exeinto /usr/lib/${PN}
+ doexe misc/bootsplash_resizer.pl
+
+ dodir /etc/${PN}
+ cp -pR themes/* ${D}/etc/${PN}
+
+ # link default config for boot images if not already set
+ if [ ! -e ${ROOT}/etc/bootsplash/default ]; then
+ dosym ./gentoo /etc/bootsplash/default
+ fi
+
+ exeinto /etc/init.d
+ doexe misc/bootsplash
+
+ insinto /etc/conf.d
+ newins misc/bootsplash.conf bootsplash
+
+ insinto /usr/share/${PN}
+ doins kernel/*.bz2 misc/grub.conf.sample
+
+ into /
+ dosbin misc/bootsplash_patch misc/bootsplash_initrdgen
+ fperms 0754 /sbin/bootsplash_patch /sbin/bootsplash_initrdgen
+}
+
+pkg_postinst() {
+ # has to be done here so that the initrd images are created properly
+ if [ "${ROOT}" = "/" ]
+ then
+ /sbin/bootsplash_initrdgen --all
+ fi
+
+ # rename bootsplash config file to fit with the standard
+ if [ -f ${ROOT}/etc/conf.d/bootsplash.conf ]
+ then
+ mv -f ${ROOT}/etc/conf.d/bootsplash.conf ${ROOT}/etc/conf.d/bootsplash
+ fi
+
+ echo ""
+ einfo "Execute \`bootsplash_patch\` to have your kernel sources in"
+ einfo "/usr/src/linux patched with the Framebuffer Bootsplash patches."
+ einfo
+ einfo "You can also use:"
+ einfo " bootsplash_patch /path/to/your/custom/kernel/"
+ einfo "to patch your custom kernel sources."
+ echo ""
+ ewarn "If you have already patched the kernel then you only need to copy"
+ ewarn "an initrd from /usr/share/${PN} to /boot"
+ echo ""
+ einfo "Run:"
+ einfo " rc-update add bootsplash default"
+ einfo "to change the console images after startup"
+ echo ""
+ einfo "If you want to automatically generate configs for a new resolution"
+ einfo "you can use the \`bootsplash_resize\` script. More info:"
+ einfo " bootsplash_resize -h"
+ echo ""
+}
diff --git a/media-gfx/bootsplash/files/digest-bootsplash-0.6.1-r3 b/media-gfx/bootsplash/files/digest-bootsplash-0.6.1-r3
new file mode 100644
index 000000000000..1809391ed1c4
--- /dev/null
+++ b/media-gfx/bootsplash/files/digest-bootsplash-0.6.1-r3
@@ -0,0 +1,3 @@
+MD5 3239a26db6f846bc45d79248cb49e9b7 bootsplash-core-0.6.1-r3.tar.bz2 127943
+MD5 1d93157ac8796a86cc269b24bb882769 bootsplash-themes-0.6.1.tar.bz2 416892
+MD5 4d1c0aae57ea6252390aca019e72feb0 bootsplash-kernel-0.6.1-r3.tar.bz2 157480