summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-20 09:20:57 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-20 09:20:57 +0000
commit23a43056ffefa0ac084a225acb17e0712a97faa6 (patch)
tree9e14deae6edb339222c5f8d1b749cf9416a55989 /media-gfx/sodipodi
parentNew package net-misc/bind-tools. Builds and installs only the (diff)
downloadhistorical-23a43056ffefa0ac084a225acb17e0712a97faa6.tar.gz
historical-23a43056ffefa0ac084a225acb17e0712a97faa6.tar.bz2
historical-23a43056ffefa0ac084a225acb17e0712a97faa6.zip
added gdk-pixbuf-flags to CFLAGS
Diffstat (limited to 'media-gfx/sodipodi')
-rw-r--r--media-gfx/sodipodi/files/digest-sodipodi-0.24.1-r21
-rw-r--r--media-gfx/sodipodi/sodipodi-0.24.1-r2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/media-gfx/sodipodi/files/digest-sodipodi-0.24.1-r2 b/media-gfx/sodipodi/files/digest-sodipodi-0.24.1-r2
new file mode 100644
index 000000000000..65ab3730fdbf
--- /dev/null
+++ b/media-gfx/sodipodi/files/digest-sodipodi-0.24.1-r2
@@ -0,0 +1 @@
+MD5 1bb1c07993e6cee32ae2b2d8c39b9b40 sodipodi-0.24.1.tar.gz 1290240
diff --git a/media-gfx/sodipodi/sodipodi-0.24.1-r2.ebuild b/media-gfx/sodipodi/sodipodi-0.24.1-r2.ebuild
new file mode 100644
index 000000000000..b4d70353722d
--- /dev/null
+++ b/media-gfx/sodipodi/sodipodi-0.24.1-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <micke@hallendal.net>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sodipodi/sodipodi-0.24.1-r2.ebuild,v 1.1 2001/11/20 09:20:57 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Vector illustrating application for GNOME"
+SRC_URI="http://prdownloads.sourceforge.net/${PN}/${A}"
+HOMEPAGE="http://sodipodi.sourceforge.net/"
+
+RDEPEND=">=gnome-base/gnome-print-0.30
+ >=gnome-extra/gal-0.13-r1
+ ? ( >=gnome-base/bonobo-1.0.9-r1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-compile.patch
+ automake
+}
+
+src_compile() {
+ local myconf
+
+ if [ "`use bonobo`" ] ; then
+ myconf="--with-bonobo"
+ else
+ myconf="--without-bonobo"
+ fi
+
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} `gnome-config --cflags gdk_pixbuf`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-gnome \
+ --enable-gnome-print ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO
+}