summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-09 10:32:34 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-09 10:32:34 +0000
commit92beee5aa24725fc1f1a4d20e5aa793cb1dd500b (patch)
tree0e1c57d4dcd9a6bf57175aeedcd85e864192b2c6 /media-gfx/sodipodi
parent*** empty log message *** (diff)
downloadhistorical-92beee5aa24725fc1f1a4d20e5aa793cb1dd500b.tar.gz
historical-92beee5aa24725fc1f1a4d20e5aa793cb1dd500b.tar.bz2
historical-92beee5aa24725fc1f1a4d20e5aa793cb1dd500b.zip
*** empty log message ***
Diffstat (limited to 'media-gfx/sodipodi')
-rw-r--r--media-gfx/sodipodi/files/digest-sodipodi-0.231
-rw-r--r--media-gfx/sodipodi/sodipodi-0.23.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/sodipodi/files/digest-sodipodi-0.23 b/media-gfx/sodipodi/files/digest-sodipodi-0.23
new file mode 100644
index 000000000000..94a1916488b3
--- /dev/null
+++ b/media-gfx/sodipodi/files/digest-sodipodi-0.23
@@ -0,0 +1 @@
+MD5 947dcc478cb871b36da72b5938c466df sodipodi-0.23.tar.gz
diff --git a/media-gfx/sodipodi/sodipodi-0.23.ebuild b/media-gfx/sodipodi/sodipodi-0.23.ebuild
new file mode 100644
index 000000000000..5094edbcfac7
--- /dev/null
+++ b/media-gfx/sodipodi/sodipodi-0.23.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <micke@hallendal.net>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Vector illustrating application for GNOME"
+SRC_URI="http://prdownloads.sourceforge.net/sodipodi/${A}"
+HOMEPAGE="http://sodipodi.sourceforge.net/"
+
+DEPEND=">=gnome-base/gnome-print-0.21 nls? ( sys-devel/gettext )
+ >=gnome-base/gal-0.4
+ bonobo? ( >=gnome-base/bonobo-0.37 )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use bonobo`" ]
+ then
+ myconf="--with-bonobo"
+ else
+ myconf="--without-bonobo"
+ fi
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome \
+ --enable-gnome --enable-gnome-print ${myconf}
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO
+
+}
+
+
+
+
+