summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-11-10 12:43:53 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-11-10 12:43:53 +0000
commit1013d0e3e53e84786a017f56f53309f662df6442 (patch)
treeb4f21b49d5e6622f8ed1786605ce8bb77a093a10 /media-gfx
parentVersion bump. Wiped out previous release. Local USE flags names rationalized.... (diff)
downloadhistorical-1013d0e3e53e84786a017f56f53309f662df6442.tar.gz
historical-1013d0e3e53e84786a017f56f53309f662df6442.tar.bz2
historical-1013d0e3e53e84786a017f56f53309f662df6442.zip
remove old versions, use gnome2_src_unpack to fix #154631 , cleanup ebuilds
Package-Manager: portage-2.1.2_rc1-r1
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gtkam/ChangeLog7
-rw-r--r--media-gfx/gtkam/gtkam-0.1.12-r1.ebuild11
-rw-r--r--media-gfx/gtkam/gtkam-0.1.12-r2.ebuild21
3 files changed, 25 insertions, 14 deletions
diff --git a/media-gfx/gtkam/ChangeLog b/media-gfx/gtkam/ChangeLog
index 4c766712ab4e..01da49df36d9 100644
--- a/media-gfx/gtkam/ChangeLog
+++ b/media-gfx/gtkam/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/gtkam
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/ChangeLog,v 1.38 2006/04/27 22:56:52 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/ChangeLog,v 1.39 2006/11/10 12:43:53 allanonjl Exp $
+
+ 10 Nov 2006; John N. Laliberte <allanonjl@gentoo.org>
+ -gtkam-0.1.10-r1.ebuild, -gtkam-0.1.11.ebuild, -gtkam-0.1.12.ebuild,
+ gtkam-0.1.12-r1.ebuild, gtkam-0.1.12-r2.ebuild:
+ remove old versions, use gnome2_src_unpack to fix #154631 , cleanup ebuilds
27 Apr 2006; Marien Zwart <marienz@gentoo.org>
files/digest-gtkam-0.1.10-r1, files/digest-gtkam-0.1.11,
diff --git a/media-gfx/gtkam/gtkam-0.1.12-r1.ebuild b/media-gfx/gtkam/gtkam-0.1.12-r1.ebuild
index f391fa8ec89b..b45b057c9165 100644
--- a/media-gfx/gtkam/gtkam-0.1.12-r1.ebuild
+++ b/media-gfx/gtkam/gtkam-0.1.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/gtkam-0.1.12-r1.ebuild,v 1.4 2006/01/05 14:31:11 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/gtkam-0.1.12-r1.ebuild,v 1.5 2006/11/10 12:43:53 allanonjl Exp $
inherit eutils gnome2
@@ -24,10 +24,10 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-0.1.10-norpm.patch
- epatch ${FILESDIR}/${PN}-0.1.12-helpdoc.patch
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}/${PN}-0.1.10-norpm.patch"
+ epatch "${FILESDIR}/${PN}-0.1.12-helpdoc.patch"
}
src_compile() {
@@ -37,6 +37,7 @@ src_compile() {
$(use_with gnome gnome) \
$(use_with gnome bonobo) \
--with-rpmbuild=/bin/false --without-gimp
+
emake || die
}
diff --git a/media-gfx/gtkam/gtkam-0.1.12-r2.ebuild b/media-gfx/gtkam/gtkam-0.1.12-r2.ebuild
index 51962c1f1d8a..fa0507589bc0 100644
--- a/media-gfx/gtkam/gtkam-0.1.12-r2.ebuild
+++ b/media-gfx/gtkam/gtkam-0.1.12-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/gtkam-0.1.12-r2.ebuild,v 1.5 2006/03/09 23:53:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/gtkam-0.1.12-r2.ebuild,v 1.6 2006/11/10 12:43:53 allanonjl Exp $
inherit eutils gnome2
@@ -17,6 +17,7 @@ RDEPEND=">=x11-libs/gtk+-2
>=media-libs/libgphoto2-2.1.6
exif? ( media-libs/libexif-gtk media-libs/libexif )
gnome? ( >=gnome-base/libbonobo-2 >=gnome-base/libgnomeui-2 )"
+
DEPEND="${RDEPEND}
dev-util/pkgconfig
nls? ( sys-devel/gettext )"
@@ -24,20 +25,24 @@ DEPEND="${RDEPEND}
DOCS="ABOUT-NLS AUTHORS MANUAL NEWS README"
pkg_setup() {
- G2CONF="${G2CONF} $(use_enable nls) $(use_enable exif) $(use_with gnome) \
- $(use_with gnome bonobo) --with-rpmbuild=/bin/false --without-gimp"
+ G2CONF="${G2CONF} \
+ $(use_enable nls) \
+ $(use_enable exif) \
+ $(use_with gnome) \
+ $(use_with gnome bonobo) \
+ --with-rpmbuild=/bin/false --without-gimp"
}
src_unpack() {
- unpack ${A}
- cd ${S}
+ gnome2_src_unpack
- epatch ${FILESDIR}/${PN}-0.1.10-norpm.patch
- epatch ${FILESDIR}/${PN}-0.1.12-helpdoc.patch
- epatch ${FILESDIR}/${PN}-0.1.12-desktop-image.patch
+ epatch "${FILESDIR}/${PN}-0.1.10-norpm.patch"
+ epatch "${FILESDIR}/${PN}-0.1.12-helpdoc.patch"
+ epatch "${FILESDIR}/${PN}-0.1.12-desktop-image.patch"
}
src_install() {
gnome2_src_install
+
rm -rf ${D}/usr/share/doc/gtkam
}