summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-08-03 05:04:18 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-08-03 05:04:18 +0000
commit1e6a7933edfd47d617486b56cdfe1bfaddf094e5 (patch)
tree9b597f6eed1e78cdddd12c5e45430367c4f48863 /media-gfx
parentFinally got echangelog to work! It didn't handle my incorrectly configured cv... (diff)
downloadhistorical-1e6a7933edfd47d617486b56cdfe1bfaddf094e5.tar.gz
historical-1e6a7933edfd47d617486b56cdfe1bfaddf094e5.tar.bz2
historical-1e6a7933edfd47d617486b56cdfe1bfaddf094e5.zip
Fixes #25758. jpg, png, tiff compile support
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xv/ChangeLog5
-rw-r--r--media-gfx/xv/xv-3.10a-r4.ebuild16
2 files changed, 19 insertions, 2 deletions
diff --git a/media-gfx/xv/ChangeLog b/media-gfx/xv/ChangeLog
index c15322e5bd33..1a13e68b0b1d 100644
--- a/media-gfx/xv/ChangeLog
+++ b/media-gfx/xv/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for media-gfx/xv
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/ChangeLog,v 1.15 2003/07/31 21:22:52 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/ChangeLog,v 1.16 2003/08/03 05:04:18 rphillips Exp $
27 May 2003; Tavis Ormandy <taviso@gentoo.org> xv-3.10a-r3.ebuild:
ccc support
@@ -12,6 +12,9 @@
*xv-3.10a-r4 (31 Jul 2003)
+ 02 Aug 2003; Ryan Phillips <rphillips@gentoo.org> xv-3.10a-r4.ebuild :
+ included Martin Ehmsen's patch to the ebuild added jpg, png and tiff support
+
31 Jul 2003; Ryan Phillips <rphillips@gentoo.org> xv-3.10a-r4.ebuild :
Added Dean Baender's contribution of changes #20092. Patch to read photoCDs,
and the xv author's own patches.
diff --git a/media-gfx/xv/xv-3.10a-r4.ebuild b/media-gfx/xv/xv-3.10a-r4.ebuild
index ce10ae4d73dc..e653adc3ec9d 100644
--- a/media-gfx/xv/xv-3.10a-r4.ebuild
+++ b/media-gfx/xv/xv-3.10a-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/xv-3.10a-r4.ebuild,v 1.1 2003/07/31 21:22:52 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/xv-3.10a-r4.ebuild,v 1.2 2003/08/03 05:04:18 rphillips Exp $
IUSE="jpeg tiff png zlib X"
@@ -34,6 +34,20 @@ src_unpack() {
}
src_compile() {
+ if [ `use jpeg` ]
+ then
+ export CFLAGS="${CFLAGS} -DDOJPEG"
+ fi
+
+ if [ `use png` ]
+ then
+ export CFLAGS="${CFLAGS} -DDOPNG"
+ fi
+
+ if [ `use tiff` ]
+ then
+ export CFLAGS="${CFLAGS} -DDOTIFF"
+ fi
mv Makefile Makefile.orig
sed -e "s:CCOPTS = -O:CCOPTS = ${CFLAGS}:" \
Makefile.orig > Makefile