summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-03-07 15:53:22 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-03-07 15:53:22 +0000
commitec426fc9a2af5ff12c39fea799a9bab0444af162 (patch)
tree6c245d99b7ca19eb50322fb8d4c5c3e61ed8c60c /media-gfx
parentmake wrapper script automagic (diff)
downloadhistorical-ec426fc9a2af5ff12c39fea799a9bab0444af162.tar.gz
historical-ec426fc9a2af5ff12c39fea799a9bab0444af162.tar.bz2
historical-ec426fc9a2af5ff12c39fea799a9bab0444af162.zip
marked 4.2.5 stable x86 ; added 4.2.5-r1 (bug #14909) for testing
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gimp-print/ChangeLog8
-rw-r--r--media-gfx/gimp-print/files/digest-gimp-print-4.2.5-r11
-rw-r--r--media-gfx/gimp-print/gimp-print-4.2.5-r1.ebuild86
-rw-r--r--media-gfx/gimp-print/gimp-print-4.2.5.ebuild4
4 files changed, 96 insertions, 3 deletions
diff --git a/media-gfx/gimp-print/ChangeLog b/media-gfx/gimp-print/ChangeLog
index b5f63a053e44..da6f3f98879c 100644
--- a/media-gfx/gimp-print/ChangeLog
+++ b/media-gfx/gimp-print/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for media-gfx/gimp-print
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/ChangeLog,v 1.11 2003/02/22 04:42:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/ChangeLog,v 1.12 2003/03/07 15:53:22 lordvan Exp $
*gimp-print-4.2.5 (28 Jan 2003)
+ 07 Mar 2003; Thomas Raschbacher <lordvan@gentoo.org> gimp-print-4.2.5.ebuild:
+ Mark stable on x86
+
+ 07 Mar 2003; Thomas Raschbacher <lordvan@gentoo.org> gimp-print-4.2.5-r1.ebuild:
+ should now work with gimp-1.3 only too - please test (bug #14909)
+
21 Feb 2003; Aron Griffis <agriffis@gentoo.org> gimp-print-4.2.5.ebuild :
Mark stable on Alpha
diff --git a/media-gfx/gimp-print/files/digest-gimp-print-4.2.5-r1 b/media-gfx/gimp-print/files/digest-gimp-print-4.2.5-r1
new file mode 100644
index 000000000000..0c10e01131a6
--- /dev/null
+++ b/media-gfx/gimp-print/files/digest-gimp-print-4.2.5-r1
@@ -0,0 +1 @@
+MD5 82a75fa7c97423b1a787df41552da3cc gimp-print-4.2.5.tar.gz 4992416
diff --git a/media-gfx/gimp-print/gimp-print-4.2.5-r1.ebuild b/media-gfx/gimp-print/gimp-print-4.2.5-r1.ebuild
new file mode 100644
index 000000000000..f365d71e7aa7
--- /dev/null
+++ b/media-gfx/gimp-print/gimp-print-4.2.5-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.5-r1.ebuild,v 1.1 2003/03/07 15:53:22 lordvan Exp $
+
+IUSE="cups doc nls"
+
+inherit libtool
+
+MY_P=${P}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Gimp Plugin and Ghostscript driver for Gimp"
+SRC_URI="mirror://sourceforge/gimp-print/${MY_P}.tar.gz"
+HOMEPAGE="http://gimp-print.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=media-gfx/gimp-1.2.3
+ app-text/ghostscript
+ net-print/foomatic
+ doc? ( app-text/texi2html )
+ cups? ( >=net-print/cups-1.1.16 )"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ elibtoolize
+ aclocal
+
+ local myconf
+
+ use cups && myconf="${myconf} --with-cups" \
+ || myconf="${myconf} --without-cups"
+
+ use nls && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ else
+ myconf="${myconf} --disable-debug"
+ fi
+
+ has_version =media-gfx/gimp-1.2* && \
+ myconf='${myconf} --sysconfdir=/etc/gimp/1.2/' || \
+ myconf='${myconf} --sysconfdir=/etc/gimp/1.3/'
+
+ econf \
+ --with-ghost \
+ --with-gimp-exec-prefix=/usr \
+ --with-testpattern \
+ ${myconf} || die
+
+ cp src/gimp/Makefile src/gimp/Makefile.orig
+ sed -e 's:--install-admin-bin:--install-bin:g' \
+ src/gimp/Makefile.orig >src/gimp/Makefile
+
+ emake || die
+
+}
+
+src_install() {
+
+ dodir /usr/lib/gimp/1.2/.gimp-1.2/plug-ins/print
+
+ make \
+ DESTDIR=${D} \
+ HOME=/usr/lib/gimp/1.2 \
+ install || die "make install failed"
+
+ # NOTE: this build uses gimptool to install the plugin, so
+ # if we dont do it this way, it will install to / no
+ # matter what.
+ #
+ # NOTE to whoever commented this: Please DO NOT!
+ mv ${D}/usr/lib/gimp/1.2/.gimp-1.2/plug-ins/ \
+ ${D}/usr/lib/gimp/1.2/
+ rm -rf ${D}/usr/lib/gimp/1.2/.gimp-1.2/
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README*
+ dohtml -r doc
+
+}
diff --git a/media-gfx/gimp-print/gimp-print-4.2.5.ebuild b/media-gfx/gimp-print/gimp-print-4.2.5.ebuild
index c0699b53131b..c55b156ea22c 100644
--- a/media-gfx/gimp-print/gimp-print-4.2.5.ebuild
+++ b/media-gfx/gimp-print/gimp-print-4.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.5.ebuild,v 1.3 2003/02/22 04:42:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.5.ebuild,v 1.4 2003/03/07 15:53:22 lordvan Exp $
IUSE="cups doc nls"
@@ -15,7 +15,7 @@ HOMEPAGE="http://gimp-print.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc alpha ~sparc"
+KEYWORDS="x86 ~ppc alpha ~sparc"
DEPEND="=x11-libs/gtk+-1.2*
=media-gfx/gimp-1.2*