summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-09-28 18:16:55 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-09-28 18:16:55 +0000
commiteb95dde7122d40c4628892d0615f1b51a168def7 (patch)
tree1d145dcebfda396bc2aeaa986574152b1d7c5bf4 /media-libs/bio2jack
parentResolve 65695. (diff)
downloadhistorical-eb95dde7122d40c4628892d0615f1b51a168def7.tar.gz
historical-eb95dde7122d40c4628892d0615f1b51a168def7.tar.bz2
historical-eb95dde7122d40c4628892d0615f1b51a168def7.zip
Added static USE flag support.
Diffstat (limited to 'media-libs/bio2jack')
-rw-r--r--media-libs/bio2jack/ChangeLog6
-rw-r--r--media-libs/bio2jack/Manifest4
-rw-r--r--media-libs/bio2jack/bio2jack-0.3-r1.ebuild10
3 files changed, 15 insertions, 5 deletions
diff --git a/media-libs/bio2jack/ChangeLog b/media-libs/bio2jack/ChangeLog
index 5131ccca5caa..af6c679cd04b 100644
--- a/media-libs/bio2jack/ChangeLog
+++ b/media-libs/bio2jack/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/bio2jack
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/bio2jack/ChangeLog,v 1.4 2004/09/28 06:56:55 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/bio2jack/ChangeLog,v 1.5 2004/09/28 18:16:55 eradicator Exp $
+
+ 28 Sep 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ bio2jack-0.3-r1.ebuild:
+ Added static USE flag support.
*bio2jack-0.3-r1 (27 Sep 2004)
diff --git a/media-libs/bio2jack/Manifest b/media-libs/bio2jack/Manifest
index f7ce9a010954..d2520e9e1f78 100644
--- a/media-libs/bio2jack/Manifest
+++ b/media-libs/bio2jack/Manifest
@@ -1,4 +1,4 @@
-MD5 5b2f0852d80204be0019a4e80466e047 ChangeLog 1385
+MD5 38e987aee707d9b92d28901547c6a768 ChangeLog 1502
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
-MD5 fed197a0e39540dd4a820180c8a87e34 bio2jack-0.3-r1.ebuild 904
+MD5 7204f1fec8a4afe7ff1fda203bf05437 bio2jack-0.3-r1.ebuild 978
MD5 7d81cae028507a4e4b66e9ea04afaf56 files/digest-bio2jack-0.3-r1 64
diff --git a/media-libs/bio2jack/bio2jack-0.3-r1.ebuild b/media-libs/bio2jack/bio2jack-0.3-r1.ebuild
index a3106e3c97bb..875b924b2169 100644
--- a/media-libs/bio2jack/bio2jack-0.3-r1.ebuild
+++ b/media-libs/bio2jack/bio2jack-0.3-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/bio2jack/bio2jack-0.3-r1.ebuild,v 1.2 2004/09/28 06:56:55 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/bio2jack/bio2jack-0.3-r1.ebuild,v 1.3 2004/09/28 18:16:55 eradicator Exp $
+
+IUSE="static"
inherit libtool
@@ -11,7 +13,6 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
-IUSE=""
RDEPEND=">=media-sound/jack-audio-connection-kit-0.80"
DEPEND="${RDEPEND}
@@ -30,6 +31,11 @@ src_unpack() {
elibtoolize || die
}
+src_compile() {
+ econf `use_enable static` || die
+ emake || die
+}
+
src_install() {
make DESTDIR="${D}" install || die
dobin bio2jack-config