summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-22 14:37:06 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-22 14:37:06 +0000
commit43480cafff7d0e6202a391ad867fa8b9ecf05673 (patch)
tree28c65e3696f5ac45856b3fd377e0ca74cd88cd6d /media-libs/hermes/hermes-1.3.2-r2.ebuild
parentadded 3dfx's GPL (diff)
downloadhistorical-43480cafff7d0e6202a391ad867fa8b9ecf05673.tar.gz
historical-43480cafff7d0e6202a391ad867fa8b9ecf05673.tar.bz2
historical-43480cafff7d0e6202a391ad867fa8b9ecf05673.zip
repoman'd
Diffstat (limited to 'media-libs/hermes/hermes-1.3.2-r2.ebuild')
-rw-r--r--media-libs/hermes/hermes-1.3.2-r2.ebuild39
1 files changed, 21 insertions, 18 deletions
diff --git a/media-libs/hermes/hermes-1.3.2-r2.ebuild b/media-libs/hermes/hermes-1.3.2-r2.ebuild
index 140d5df2095e..fc2358c45011 100644
--- a/media-libs/hermes/hermes-1.3.2-r2.ebuild
+++ b/media-libs/hermes/hermes-1.3.2-r2.ebuild
@@ -1,13 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hermes/hermes-1.3.2-r2.ebuild,v 1.2 2002/07/11 06:30:38 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hermes/hermes-1.3.2-r2.ebuild,v 1.3 2002/07/22 14:37:06 seemant Exp $
-PN0=Hermes
-S=${WORKDIR}/${PN0}-${PV}
+MY_P=${P/h/H}
+S=${WORKDIR}/${MY_P}
DESCRIPTION="Library for fast colorspace conversion and other graphics routines"
-SRC_URI="http://dark.x.dtu.dk/~mbn/clanlib/download/download-sphair/${PN0}-${PV}.tar.gz"
+SRC_URI="http://dark.x.dtu.dk/~mbn/clanlib/download/download-sphair/${MY_P}.tar.gz"
HOMEPAGE="http://hermes.terminal.at"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86"
+
DEPEND="sys-devel/libtool
sys-devel/automake
sys-devel/autoconf"
@@ -18,28 +22,27 @@ src_compile() {
automake -a
autoconf || die
- ./configure \
- --prefix=/usr \
- || die
+ ./configure \
+ --prefix=/usr || die
- sh ltconfig ltmain.sh || die
- emake || die
+ sh ltconfig ltmain.sh || die
+ emake || die
}
src_install () {
- make \
+ make \
prefix=${D}/usr \
install || die
- dodoc AUTHORS COPYING ChangeLog FAQ NEWS README TODO*
+ dodoc AUTHORS COPYING ChangeLog FAQ NEWS README TODO*
- dohtml docs/api/*.htm
- docinto print
- dodoc docs/api/*.ps
- docinto txt
- dodoc docs/api/*.txt
- docinto sgml
- dodoc docs/api/sgml/*.sgml
+ dohtml docs/api/*.htm
+ docinto print
+ dodoc docs/api/*.ps
+ docinto txt
+ dodoc docs/api/*.txt
+ docinto sgml
+ dodoc docs/api/sgml/*.sgml
}