summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-10-20 02:41:52 +0000
committerMax Kalika <max@gentoo.org>2003-10-20 02:41:52 +0000
commit442ed9ac1e76ad73d5a4883cba3fc6a103786400 (patch)
tree9bc2efb8d22805c6c9a63fef479838777ff2d8a4 /media-libs/libdvb/libdvb-0.5.0-r1.ebuild
parentmake compile failure die the ebuild (diff)
downloadhistorical-442ed9ac1e76ad73d5a4883cba3fc6a103786400.tar.gz
historical-442ed9ac1e76ad73d5a4883cba3fc6a103786400.tar.bz2
historical-442ed9ac1e76ad73d5a4883cba3fc6a103786400.zip
Bring the 0.5.0 version to media-libs. Ditch DVB.cc patch as it has been fixed upstream. Consolidate the other two patches into one and use epatch. Properly install sample_progs and samplerc items.
Diffstat (limited to 'media-libs/libdvb/libdvb-0.5.0-r1.ebuild')
-rw-r--r--media-libs/libdvb/libdvb-0.5.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/libdvb/libdvb-0.5.0-r1.ebuild b/media-libs/libdvb/libdvb-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..5583d143c780
--- /dev/null
+++ b/media-libs/libdvb/libdvb-0.5.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvb/libdvb-0.5.0-r1.ebuild,v 1.1 2003/10/20 02:41:51 max Exp $
+
+DESCRIPTION="libdvb package with added CAM library and libdvbmpegtools as well as dvb-mpegtools"
+HOMEPAGE="http://www.metzlerbros.org/dvb/"
+SRC_URI="http://www.metzlerbros.org/dvb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=sys-apps/sed-4
+ >=media-tv/linuxtv-dvb-1.0.1"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ # Disable compilation of sample programs
+ # and use DESTDIR when installing
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_compile() {
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR="${D}" PREFIX=/usr install || die
+
+ insinto "/usr/share/doc/${PF}/sample_progs"
+ doins sample_progs/*
+ insinto "/usr/share/doc/${PF}/samplerc"
+ doins samplerc/*
+
+ dodoc README
+}