summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2004-10-25 20:04:24 +0000
committerAnders Rune Jensen <arj@gentoo.org>2004-10-25 20:04:24 +0000
commitd0e46b11cb31a66c656c71ed6e763449b1355bee (patch)
treea8a3ab1052f1e464ac5bd39f0c3f06fff0cfe8cb /media-libs/libmatroska/libmatroska-0.7.4.ebuild
parentnew version (diff)
downloadhistorical-d0e46b11cb31a66c656c71ed6e763449b1355bee.tar.gz
historical-d0e46b11cb31a66c656c71ed6e763449b1355bee.tar.bz2
historical-d0e46b11cb31a66c656c71ed6e763449b1355bee.zip
new version
Diffstat (limited to 'media-libs/libmatroska/libmatroska-0.7.4.ebuild')
-rw-r--r--media-libs/libmatroska/libmatroska-0.7.4.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/libmatroska/libmatroska-0.7.4.ebuild b/media-libs/libmatroska/libmatroska-0.7.4.ebuild
new file mode 100644
index 000000000000..d62aac2f55d7
--- /dev/null
+++ b/media-libs/libmatroska/libmatroska-0.7.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/libmatroska-0.7.4.ebuild,v 1.1 2004/10/25 20:04:24 arj Exp $
+
+IUSE=""
+
+inherit flag-o-matic gcc eutils
+
+DESCRIPTION="Extensible multimedia container format based on EBML"
+HOMEPAGE="http://www.matroska.org/"
+SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-libs/libebml-0.7.2"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/libmatroska-shared.patch
+
+ cd ${S}/make/linux
+ sed -i -e 's/CXXFLAGS=/CXXFLAGS+=/g' Makefile
+}
+
+src_compile() {
+ cd ${S}/make/linux
+
+ # This is needed on amd64 to create shared libraries that make
+ # use of matroska, like libvlcplugin from vlc.
+ # Travis Tilley <lv@gentoo.org> 09 Apr 2004
+ use amd64 && append-flags -fPIC
+ use ppc && append-flags -fPIC
+
+ #fixes locale for gcc3.4.0 to close bug 52385
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ then
+ append-flags -finput-charset=ISO8859-15
+ fi
+
+ make PREFIX=/usr \
+ LIBEBML_INCLUDE_DIR=/usr/include/ebml \
+ LIBEBML_LIB_DIR=/usr/$(get_libdir) || die "make failed"
+}
+
+src_install() {
+ cd ${S}/make/linux
+
+ einstall libdir="${D}/usr/$(get_libdir)" || die "make install failed"
+ dodoc ../../ChangeLog
+}