summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-12 20:05:25 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-12 20:05:25 +0000
commit5f4b371245f370ec381febc30f8269d1f14d3d4a (patch)
tree370ba34cf1b427166c28f5ccc1a83694ca6e7441 /media-libs/libsdl
parentsvg support (diff)
downloadhistorical-5f4b371245f370ec381febc30f8269d1f14d3d4a.tar.gz
historical-5f4b371245f370ec381febc30f8269d1f14d3d4a.tar.bz2
historical-5f4b371245f370ec381febc30f8269d1f14d3d4a.zip
version bump
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/ChangeLog10
-rw-r--r--media-libs/libsdl/files/digest-libsdl-1.2.51
-rw-r--r--media-libs/libsdl/libsdl-1.2.5.ebuild135
3 files changed, 145 insertions, 1 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index 4c01cc72ef6e..064087239368 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/libsdl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.11 2002/09/11 20:45:19 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.12 2002/10/12 20:05:25 seemant Exp $
+
+*libsdl-1.2.5 (12 Oct 2002)
+
+ 12 Oct 2002; Seemant Kulleen <seemant@gentoo.org> libsdl-1.2.5.ebuild
+ files/digest-libsdl-1.2.5 :
+
+ Version bump. Ebuild submitted by: wongs15@tartarus.uwa.edu.au (Steven
+ Wong) in bug #8979
*libsdl-1.2.3-r1 (16 Aug 2002)
diff --git a/media-libs/libsdl/files/digest-libsdl-1.2.5 b/media-libs/libsdl/files/digest-libsdl-1.2.5
new file mode 100644
index 000000000000..7f81a2ad2402
--- /dev/null
+++ b/media-libs/libsdl/files/digest-libsdl-1.2.5
@@ -0,0 +1 @@
+MD5 cacacf4e4cca546de168fedc23b9b44b SDL-1.2.5.tar.gz 1854550
diff --git a/media-libs/libsdl/libsdl-1.2.5.ebuild b/media-libs/libsdl/libsdl-1.2.5.ebuild
new file mode 100644
index 000000000000..9718054e21da
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.2.5.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.5.ebuild,v 1.1 2002/10/12 20:05:25 seemant Exp $
+
+IUSE="arts xv opengl fbcon aalib nas esd X svga ggi alsa directfb"
+
+S=${WORKDIR}/SDL-${PV}
+DESCRIPTION="Simple Direct Media Layer"
+SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
+HOMEPAGE="http://www.libsdl.org/"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86"
+
+RDEPEND=">=media-libs/audiofile-0.1.9
+ X? ( virtual/x11 )
+ esd? ( >=media-sound/esound-0.2.19 )
+ ggi? ( >=media-libs/libggi-2.0_beta3 )
+ nas? ( media-libs/nas )
+ alsa? ( media-libs/alsa-lib )
+ arts? ( kde-base/arts )
+ svga? ( >=media-libs/svgalib-1.4.2 )
+ opengl? ( virtual/opengl )
+ directfb? ( dev-libs/DirectFB )"
+
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+
+#src_unpack() {
+
+ #unpack ${A}
+ # cd ${S}/src/video/directfb
+ # cp SDL_DirectFB_events.c SDL_DirectFB_events.c.orig
+ # sed -e "s:DIKI_CTRL:DIKI_CONTROL_L:" \
+ # -e "s:DIKI_SHIFT:DIKI_SHIFT_L:" \
+ # -e "s:DIKI_ALT:DIKI_ALT_L:" \
+ # -e "s:DIKI_ALT_LGR:DIKI_ALT_R:" \
+ # -e "s:DIKI_CAPSLOCK:DIKI_CAPS_LOCK:" \
+ # -e "s:DIKI_NUMLOCK:DIKI_NUM_LOCK:" \
+ # -e "s:DIKI_SCRLOCK:DIKI_SCROLL_LOCK:" \
+ # SDL_DirectFB_events.c.orig > SDL_DirectFB_events.c
+#}
+
+src_compile() {
+ local myconf
+
+ use X \
+ && myconf="${myconf} --enable-video-x11" \
+ || myconf="${myconf} --disable-video-x11"
+
+ use xv \
+ && myconf="${myconf} --enable-video-x11-xv" \
+ || myconf="${myconf} --disable-video-x11-xv"
+
+ use esd \
+ && myconf="--enable-esd" \
+ || myconf="--disable-esd"
+
+ use ggi \
+ && myconf="${myconf} --enable-video-ggi" \
+ || myconf="${myconf} --disable-video-ggi"
+
+ use nas \
+ && myconf="${myconf} --enable-nas" \
+ || myconf="${myconf} --disable-nas"
+
+ use alsa \
+ && myconf="${myconf} --enable-alsa" \
+ || myconf="${myconf} --disable-alsa"
+
+ use arts \
+ && myconf="${myconf} --enable-arts" \
+ || myconf="${myconf} --disable-arts"
+
+ use svga \
+ && myconf="${myconf} --enable-video-svga" \
+ || myconf="${myconf} --disable-video-svga"
+
+ use aalib \
+ && myconf="${myconf} --enable-video-aalib" \
+ || myconf="${myconf} --disable-video-aalib"
+
+ use fbcon \
+ && myconf="${myconf} --enable-video-fbcon" \
+ || myconf="${myconf} --disable-video-fbcon"
+
+ use opengl \
+ && myconf="${myconf} --enable-video-opengl" \
+ || myconf="${myconf} --disable-video-opengl"
+
+ use directfb \
+ && myconf="${myconf} --enable-video-directfb" \
+ || myconf="${myconf} --disable-video-directfb"
+
+ use x86 \
+ && myconf="${myconf} --enable-nasm" \
+ || myconf="${myconf} --disable-nasm"
+
+ if use nas || use alsa || use oss || use arts || use esd
+ then
+ myconf="${myconf} --enable-audio"
+ else
+ myconf="${myconf} --disable-audio"
+ fi
+
+ if use X || use xv || use ggi || use aalib || use svga || use directfb || use fbcon || use opengl
+ then
+ myconf="${myconf} --enable-video-dummy"
+ else
+ myconf="${myconf} --disable-video"
+ fi
+
+ econf \
+ --enable-joystick \
+ --enable-cdrom \
+ --enable-threads \
+ --enable-timers \
+ --enable-endian \
+ --enable-file \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ preplib /usr
+ dodoc BUGS COPYING CREDITS README* TODO WhatsNew
+ dohtml -r ./
+}