summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-04-23 01:00:39 +0000
committerPeter Gavin <pete@gentoo.org>2001-04-23 01:00:39 +0000
commit087211d83ab3710855c312dfcaace622e58f9875 (patch)
tree765b87ad37220c9b56bff48fe2f4af897ca6e1b6 /media-libs/libvorbis
parenta fix for automake's package.mask (later revs were getting masked out) (diff)
downloadhistorical-087211d83ab3710855c312dfcaace622e58f9875.tar.gz
historical-087211d83ab3710855c312dfcaace622e58f9875.tar.bz2
historical-087211d83ab3710855c312dfcaace622e58f9875.zip
updates
Diffstat (limited to 'media-libs/libvorbis')
-rw-r--r--media-libs/libvorbis/files/digest-libvorbis-1.0_beta41
-rw-r--r--media-libs/libvorbis/libvorbis-1.0_beta4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/libvorbis/files/digest-libvorbis-1.0_beta4 b/media-libs/libvorbis/files/digest-libvorbis-1.0_beta4
new file mode 100644
index 000000000000..fd4c00377e66
--- /dev/null
+++ b/media-libs/libvorbis/files/digest-libvorbis-1.0_beta4
@@ -0,0 +1 @@
+MD5 6954d72386cbf88c613e1ffebb7b4bac libvorbis-1.0beta4.tar.gz
diff --git a/media-libs/libvorbis/libvorbis-1.0_beta4.ebuild b/media-libs/libvorbis/libvorbis-1.0_beta4.ebuild
new file mode 100644
index 000000000000..24317a8f8377
--- /dev/null
+++ b/media-libs/libvorbis/libvorbis-1.0_beta4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.0_beta4.ebuild,v 1.1 2001/04/23 01:00:39 pete Exp $
+
+
+A=libvorbis-1.0beta4.tar.gz
+S=${WORKDIR}/libvorbis-1.0beta4
+DESCRIPTION="the Ogg Vorbis sound file format library"
+SRC_URI="http://www.vorbis.com/files/beta4/unix/${A}"
+HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
+
+DEPEND=">=media-libs/libogg-1.0_beta4"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --host=${CHOST}
+ try make
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+
+ echo "Removing docs installed by make install"
+ rm -rf ${D}/usr/share/doc
+
+ dodoc AUTHORS COPYING README todo.txt
+ docinto txt
+ dodoc doc/*.txt
+ docinto html
+ dodoc doc/*.{html,png}
+ docinto html/vorbisenc
+ dodoc doc/vorbisenc/*.{css,html}
+ docinto html/vorbisfile
+ dodoc doc/vorbisfile/*.{css,html}
+}
+