summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-03 11:39:13 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-03 11:39:13 +0000
commit3dbc4ea948aef055d4c31ac7dc714b23cfa8137d (patch)
treea8280e3a43c14cbaae535d0f3c5f2ec87385931b /media-libs/lv2/lv2-1.10.0.ebuild
parentRemove old (diff)
downloadhistorical-3dbc4ea948aef055d4c31ac7dc714b23cfa8137d.tar.gz
historical-3dbc4ea948aef055d4c31ac7dc714b23cfa8137d.tar.bz2
historical-3dbc4ea948aef055d4c31ac7dc714b23cfa8137d.zip
Use python-single-r1 for waf + installed Python script. Add missing Python deps.
Package-Manager: portage-2.2.15/cvs/Linux x86_64 Manifest-Sign-Key: 0xEFB4464E!
Diffstat (limited to 'media-libs/lv2/lv2-1.10.0.ebuild')
-rw-r--r--media-libs/lv2/lv2-1.10.0.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/media-libs/lv2/lv2-1.10.0.ebuild b/media-libs/lv2/lv2-1.10.0.ebuild
index bc99eeb88115..67c39dcdbc58 100644
--- a/media-libs/lv2/lv2-1.10.0.ebuild
+++ b/media-libs/lv2/lv2-1.10.0.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lv2/lv2-1.10.0.ebuild,v 1.1 2014/11/02 18:53:46 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lv2/lv2-1.10.0.ebuild,v 1.2 2015/01/03 11:39:11 mgorny Exp $
EAPI=4
-inherit waf-utils
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-single-r1 waf-utils
DESCRIPTION="LV2 is a simple but extensible successor of LADSPA"
HOMEPAGE="http://lv2plug.in/"
@@ -17,6 +19,9 @@ IUSE="doc plugins"
DEPEND="plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )"
RDEPEND="${DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
!<media-libs/slv2-0.4.2
!media-libs/lv2core
!media-libs/lv2-ui"
@@ -31,3 +36,9 @@ src_configure() {
$(use plugins || echo " --no-plugins") \
$(use doc && echo " --docs" )
}
+
+src_install() {
+ waf-utils_src_install
+
+ python_fix_shebang "${D}"
+}