summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-18 04:03:55 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-18 04:03:55 +0000
commit8d0ada62aaf41a994f998b4f1dcd00b4f5285035 (patch)
treec989a8daf380bf36718ed0098316d6ce2e7d9f1f /media-libs/mesa-glu
parentUpdate (diff)
downloadhistorical-8d0ada62aaf41a994f998b4f1dcd00b4f5285035.tar.gz
historical-8d0ada62aaf41a994f998b4f1dcd00b4f5285035.tar.bz2
historical-8d0ada62aaf41a994f998b4f1dcd00b4f5285035.zip
Update
Diffstat (limited to 'media-libs/mesa-glu')
-rw-r--r--media-libs/mesa-glu/files/digest-mesa-glu-3.4.22
-rw-r--r--media-libs/mesa-glu/mesa-glu-3.4.2.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/media-libs/mesa-glu/files/digest-mesa-glu-3.4.2 b/media-libs/mesa-glu/files/digest-mesa-glu-3.4.2
new file mode 100644
index 000000000000..59c04df9831f
--- /dev/null
+++ b/media-libs/mesa-glu/files/digest-mesa-glu-3.4.2
@@ -0,0 +1,2 @@
+MD5 9169942475db0786229079f57909f7bc MesaLib-3.4.2.tar.bz2
+MD5 b3a7b01dae8b1f09f951f9257c242b08 MesaDemos-3.4.2.tar.bz2
diff --git a/media-libs/mesa-glu/mesa-glu-3.4.2.ebuild b/media-libs/mesa-glu/mesa-glu-3.4.2.ebuild
new file mode 100644
index 000000000000..3200d0ff9456
--- /dev/null
+++ b/media-libs/mesa-glu/mesa-glu-3.4.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa-glu/mesa-glu-3.4.2.ebuild,v 1.1 2001/05/18 04:03:55 achim Exp $
+
+P=MesaLib-${PV}
+A0=${P}.tar.bz2
+A1=MesaDemos-${PV}.tar.bz2
+A="${A0} ${A1}"
+S=${WORKDIR}/Mesa-${PV}
+DESCRIPTION="OpenGL like graphic library for Linux, this package only contains the glu and glut parts"
+SRC_URI="http://download.sourceforge.net/mesa3d/${A0}
+ http://download.sourceforge.net/mesa3d/${A1}"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+
+DEPEND="virtual/glibc virtual/x11"
+
+PROVIDE="virtual/glu virtual/glut"
+
+src_compile() {
+
+ local myconf
+
+ if [ "`use mmx`" ]
+ then
+ myconf="--enable-mmx"
+ else
+ myconf="--disable-mmx"
+ fi
+
+ if [ "`use 3dnow`" ]
+ then
+ myconf="${myconf} --enable-3dnow"
+ else
+ myconf="${myconf} --disable-3dnow"
+ fi
+
+ if [ "`use sse`" ]
+ then
+ myconf="${myconf} --enable-sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+
+ myconf="${myconf} --with-x --without-glut --disable-ggi-fbdev --without-ggi"
+
+ try ./configure --prefix=/usr --sysconfdir=/etc/mesa --host=${CHOST} $myconf
+
+ try make
+
+}
+
+src_install () {
+
+
+ cd ${S}
+ try make DESTDIR=${D} install
+ cd ${D}/usr/lib
+
+ rm -f libGL.*
+
+ rm -f ../include/GL/gl.h
+ rm -f ../include/GL/glx.h
+ rm -f ../include/GL/osmesa.h
+
+ ln -s libGLU.so.1.1.030402 libMesaGLU.so.3
+
+
+ cd ${S}
+ dodoc docs/*
+}
+