summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-29 17:59:04 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-29 17:59:04 +0000
commitbfdb8bb5ddd185816294d8ae51571fcd057ec8aa (patch)
tree82851542038858f7329c6bb4f2f931317d7e4a4f /media-libs/mlt/mlt-0.9.0.ebuild
parentConvert to CPU_FLAGS_X86. (diff)
downloadhistorical-bfdb8bb5ddd185816294d8ae51571fcd057ec8aa.tar.gz
historical-bfdb8bb5ddd185816294d8ae51571fcd057ec8aa.tar.bz2
historical-bfdb8bb5ddd185816294d8ae51571fcd057ec8aa.zip
Convert to CPU_FLAGS_X86.
Package-Manager: portage-2.2.15/cvs/Linux x86_64 Manifest-Sign-Key: 0xEFB4464E!
Diffstat (limited to 'media-libs/mlt/mlt-0.9.0.ebuild')
-rw-r--r--media-libs/mlt/mlt-0.9.0.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/media-libs/mlt/mlt-0.9.0.ebuild b/media-libs/mlt/mlt-0.9.0.ebuild
index d0b39f5bb3b2..bc14f85097e2 100644
--- a/media-libs/mlt/mlt-0.9.0.ebuild
+++ b/media-libs/mlt/mlt-0.9.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.9.0.ebuild,v 1.6 2014/08/21 09:58:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.9.0.ebuild,v 1.7 2015/01/29 17:51:44 mgorny Exp $
EAPI=4
PYTHON_DEPEND="python? 2:2.6"
@@ -14,7 +14,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="compressed-lumas dv debug ffmpeg frei0r gtk jack kde kdenlive libsamplerate melt
-mmx qt4 quicktime rtaudio sdl sse sse2 vorbis xine xml lua python ruby vdpau" # java perl php tcl
+cpu_flags_x86_mmx qt4 quicktime rtaudio sdl cpu_flags_x86_sse cpu_flags_x86_sse2 vorbis xine xml lua python ruby vdpau" # java perl php tcl
IUSE="${IUSE} kernel_linux"
#rtaudio will use OSS on non linux OSes
@@ -90,8 +90,8 @@ src_configure() {
--disable-swfdec
$(use_enable debug)
$(use_enable dv)
- $(use_enable sse)
- $(use_enable sse2)
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable cpu_flags_x86_sse2 sse2)
$(use_enable gtk gtk2)
$(use_enable vorbis)
$(use_enable sdl)
@@ -115,7 +115,7 @@ src_configure() {
use compressed-lumas && myconf="${myconf} --luma-compress"
( use x86 || use amd64 ) && \
- myconf="${myconf} $(use_enable mmx)" ||
+ myconf="${myconf} $(use_enable cpu_flags_x86_mmx mmx)" ||
myconf="${myconf} --disable-mmx"
use melt || sed -i -e "s;src/melt;;" Makefile