summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-08-21 01:37:30 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-08-21 01:37:30 +0000
commitecee705435f2d29f29d983767823aa99c95954a0 (patch)
tree6659fc6d81505d2a70bd2db07c529d522019af66 /media-libs/osalp/osalp-0.7.3.ebuild
parentTypo fix (diff)
downloadhistorical-ecee705435f2d29f29d983767823aa99c95954a0.tar.gz
historical-ecee705435f2d29f29d983767823aa99c95954a0.tar.bz2
historical-ecee705435f2d29f29d983767823aa99c95954a0.zip
Initial revision. Closes #6576.
Diffstat (limited to 'media-libs/osalp/osalp-0.7.3.ebuild')
-rw-r--r--media-libs/osalp/osalp-0.7.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/osalp/osalp-0.7.3.ebuild b/media-libs/osalp/osalp-0.7.3.ebuild
new file mode 100644
index 000000000000..fedda8b90809
--- /dev/null
+++ b/media-libs/osalp/osalp-0.7.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/osalp/osalp-0.7.3.ebuild,v 1.1 2002/08/21 01:37:30 agenkin Exp $
+
+DESCRIPTION="Open Source Audio Library Project"
+HOMEPAGE="http://osalp.sourceforge.net/"
+LICENSE="GPL"
+
+DEPEND="encode? ( >=media-sound/lame-1.89 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0 )"
+
+SLOT="0"
+KEYWORDS="x86"
+SRC_URI="mirror://sourceforge/osalp/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf
+ use encode && myconf="--enable-lame"
+ use oggvorbis && myconf="${myconf} --enable-ogg"
+ ./configure \
+ ${myconf} \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc AUTHORS COPYING COPYING.LIB INSTALL README TODO NEWS
+}