summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-04 17:50:58 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-04 17:50:58 +0000
commitba5dd4b05042e49ddad67cc98dec149045819a20 (patch)
tree509f2af9490f72e1fac530e1095f980c7b176074 /media-libs/sdl-mixer
parentinitial import (diff)
downloadhistorical-ba5dd4b05042e49ddad67cc98dec149045819a20.tar.gz
historical-ba5dd4b05042e49ddad67cc98dec149045819a20.tar.bz2
historical-ba5dd4b05042e49ddad67cc98dec149045819a20.zip
gcc3 fix #27909
Diffstat (limited to 'media-libs/sdl-mixer')
-rw-r--r--media-libs/sdl-mixer/ChangeLog5
-rw-r--r--media-libs/sdl-mixer/files/1.2.5-gcc3.patch23
-rw-r--r--media-libs/sdl-mixer/sdl-mixer-1.2.5-r1.ebuild36
3 files changed, 42 insertions, 22 deletions
diff --git a/media-libs/sdl-mixer/ChangeLog b/media-libs/sdl-mixer/ChangeLog
index 0c0bceae5cb0..41b82b72a6ce 100644
--- a/media-libs/sdl-mixer/ChangeLog
+++ b/media-libs/sdl-mixer/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for media-libs/sdl-mixer
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.11 2003/03/25 00:31:45 malverian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.12 2003/09/04 17:50:58 vapier Exp $
*sdl-mixer-1.2.5-r1 (24 Mar 2003)
+ 04 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added patch so it'll detect smpeg correctly with gcc-3.x #27909.
+
24 Mar 2003; Philip Walls <malverian@gentoo.org> sdl-mixer-1.2.5-r1.ebuild,
files/digest-sdl-mixer-1.2.5-r1 :
Thanks to Jordan <lx_xero@zapo.net> for this fix; Resolves bug 18011.
diff --git a/media-libs/sdl-mixer/files/1.2.5-gcc3.patch b/media-libs/sdl-mixer/files/1.2.5-gcc3.patch
new file mode 100644
index 000000000000..0af05761164c
--- /dev/null
+++ b/media-libs/sdl-mixer/files/1.2.5-gcc3.patch
@@ -0,0 +1,23 @@
+--- acinclude.m4.orig 2003-09-04 13:34:12.116502248 -0400
++++ acinclude.m4 2003-09-04 13:35:04.337563440 -0400
+@@ -285,16 +285,11 @@
+ }
+ else
+ {
+- printf("\n*** 'smpeg-config --version' returned %d.%d.%d, but the
+-minimum version\n", $smpeg_major_version, $smpeg_minor_version,
+-$smpeg_micro_version);
+- printf("*** of SMPEG required is %d.%d.%d. If smpeg-config is
+-correct, then it is\n", major, minor, micro);
++ printf("\n*** 'smpeg-config --version' returned %d.%d.%d, but the minimum version\n", $smpeg_major_version, $smpeg_minor_version, $smpeg_micro_version);
++ printf("*** of SMPEG required is %d.%d.%d. If smpeg-config is correct, then it is\n", major, minor, micro);
+ printf("*** best to upgrade to the required version.\n");
+- printf("*** If smpeg-config was wrong, set the environment variable
+-SMPEG_CONFIG\n");
+- printf("*** to point to the correct copy of smpeg-config, and remove
+-the file\n");
++ printf("*** If smpeg-config was wrong, set the environment variable SMPEG_CONFIG\n");
++ printf("*** to point to the correct copy of smpeg-config, and remove the file\n");
+ printf("*** config.cache before re-running configure\n");
+ return 1;
+ }
diff --git a/media-libs/sdl-mixer/sdl-mixer-1.2.5-r1.ebuild b/media-libs/sdl-mixer/sdl-mixer-1.2.5-r1.ebuild
index 0ae98a14f43e..2c6e57ad0857 100644
--- a/media-libs/sdl-mixer/sdl-mixer-1.2.5-r1.ebuild
+++ b/media-libs/sdl-mixer/sdl-mixer-1.2.5-r1.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/sdl-mixer-1.2.5-r1.ebuild,v 1.2 2003/07/18 21:55:45 tester Exp $
-
-IUSE="mpeg mikmod oggvorbis"
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/sdl-mixer-1.2.5-r1.ebuild,v 1.3 2003/09/04 17:50:58 vapier Exp $
MY_P="${P/sdl-/SDL_}"
S=${WORKDIR}/${MY_P}
DESCRIPTION="Simple Direct Media Layer Mixer Library"
-SRC_URI="http://www.libsdl.org/projects/SDL_mixer/release/${MY_P}.tar.gz"
HOMEPAGE="http://www.libsdl.org/projects/SDL_mixer/index.html"
+SRC_URI="http://www.libsdl.org/projects/SDL_mixer/release/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc ~alpha amd64"
+IUSE="mpeg mikmod oggvorbis"
DEPEND=">=media-libs/libsdl-1.2.5
>=media-libs/smpeg-0.4.4-r1
@@ -20,28 +19,23 @@ DEPEND=">=media-libs/libsdl-1.2.5
oggvorbis? ( >=media-libs/libvorbis-1.0_beta4 )"
src_unpack() {
-unpack ${A}
-cd ${S}/timidity
-cp config.h config.h.orig
-sed -e 's:/usr/local/lib/timidity:/usr/share/timidity:' config.h.orig > config.h
-rm -f config.h.orig
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc3.patch
+ autoreconf
+ sed -i 's:/usr/local/lib/timidity:/usr/share/timidity:' timidity/config.h
}
src_compile() {
-
- local myconf
-
- use mikmod || myconf="${myconf} --disable-mod"
- use mpeg || myconf="${myconf} --disable-music-mp3"
- use oggvorbis || myconf="${myconf} --disable-music-ogg"
-
- econf ${myconf} || die
+ econf \
+ `use_enable mikmod mod` \
+ `use_enable mpeg music-mp3` \
+ `use_enable oggvorbis music-ogg` \
+ || die
emake || die
}
src_install() {
-
make DESTDIR=${D} install || die
-
- dodoc CHANGES COPYING README
+ dodoc CHANGES COPYING README
}