summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-08 16:16:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-08 16:16:22 +0000
commit3e4f6b7dfe0d17eacd933466b7f7d1664ed75f03 (patch)
tree172893f41afdbabd08f6b2f9c63526e5b801e4f2 /media-libs
parentQA drive, bug 35127 (diff)
downloadhistorical-3e4f6b7dfe0d17eacd933466b7f7d1664ed75f03.tar.gz
historical-3e4f6b7dfe0d17eacd933466b7f7d1664ed75f03.tar.bz2
historical-3e4f6b7dfe0d17eacd933466b7f7d1664ed75f03.zip
alsa 1.0.0 patch #35049
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsdl/ChangeLog15
-rw-r--r--media-libs/libsdl/files/1.2.6-alsa-1.0.0.patch15
-rw-r--r--media-libs/libsdl/libsdl-1.2.6-r2.ebuild8
3 files changed, 22 insertions, 16 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index 565ad8e30e7e..70879b6a2047 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,19 +1,12 @@
# ChangeLog for media-libs/libsdl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.34 2003/12/02 08:00:05 seemant Exp $
-
- 01 Dec 2003; Seemant Kulleen <seemant@gentoo.org> libsdl-1.2.6-r2.ebuild:
- epatch doesn't work
-
- 03 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> libsdl-1.2.6-r2.ebuild:
- mark stable on x86
-
- 01 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org>
- files/libsdl-1.2.6-fullscreen.patch:
- Remove rcs ids from patch so patch doesn't get confused.
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.35 2003/12/08 16:16:22 vapier Exp $
*libsdl-1.2.6-r2 (01 Nov 2003)
+ 08 Dec 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add patch to work with alsa-1.0.0 #35049.
+
01 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> libsdl-1.2.6-r2.ebuild,
files/libsdl-1.2.6-fullscreen.patch:
add patch to fix bug 31235; disable nasm for 1.2.6 since
diff --git a/media-libs/libsdl/files/1.2.6-alsa-1.0.0.patch b/media-libs/libsdl/files/1.2.6-alsa-1.0.0.patch
new file mode 100644
index 000000000000..8c5366e48a29
--- /dev/null
+++ b/media-libs/libsdl/files/1.2.6-alsa-1.0.0.patch
@@ -0,0 +1,15 @@
+diff -ur SDL-1.2.6-orig/src/audio/alsa/SDL_alsa_audio.h SDL-1.2.6/src/audio/alsa/SDL_alsa_audio.h
+--- SDL-1.2.6-orig/src/audio/alsa/SDL_alsa_audio.h 2002-06-08 12:42:11.000000000 -0500
++++ SDL-1.2.6/src/audio/alsa/SDL_alsa_audio.h 2003-12-07 17:50:47.103963328 -0600
+@@ -24,6 +24,11 @@
+ #define _ALSA_PCM_audio_h
+
+ #include "SDL_sysaudio.h"
++#include <alsa/version.h>
++# if SND_LIB_MAJOR==1
++#define ALSA_PCM_OLD_HW_PARAMS_API
++#define ALSA_PCM_NEW_HW_PARAMS_API
++# endif
+ #include <alsa/asoundlib.h>
+
+ /* Hidden "this" pointer for the video functions */
diff --git a/media-libs/libsdl/libsdl-1.2.6-r2.ebuild b/media-libs/libsdl/libsdl-1.2.6-r2.ebuild
index 0550fa6a3dc0..dacad0e94813 100644
--- a/media-libs/libsdl/libsdl-1.2.6-r2.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.6-r2.ebuild,v 1.8 2003/12/04 15:51:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.6-r2.ebuild,v 1.9 2003/12/08 16:16:22 vapier Exp $
inherit eutils
@@ -35,10 +35,8 @@ S=${WORKDIR}/SDL-${PV}
src_unpack() {
unpack ${A}
cd ${S}
- # this should fix Bug 31235
- # Cannot use epatch as this patch fails on the dry-run -- perhaps the
- # patch needs to be regenerated?
- epatch ${FILESDIR}/${P}-fullscreen.patch
+ epatch ${FILESDIR}/${P}-fullscreen.patch #31235
+ epatch ${FILESDIR}/${PV}-alsa-1.0.0.patch #35049
sed -i \
-e 's:head -1:head -n 1:' configure || \