summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-29 19:20:52 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-29 19:20:52 +0000
commit3fdbe1b696e2eaec50c8dc52813829545e68eddf (patch)
treefff8307c42415fbffc917e555d31e9fb27ea51f4 /media-libs
parentsync IUSE (-postgres) (diff)
downloadhistorical-3fdbe1b696e2eaec50c8dc52813829545e68eddf.tar.gz
historical-3fdbe1b696e2eaec50c8dc52813829545e68eddf.tar.bz2
historical-3fdbe1b696e2eaec50c8dc52813829545e68eddf.zip
only append -mno-sse3 when the gcc supports it #55011
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/Manifest10
-rw-r--r--media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild9
-rw-r--r--media-libs/xine-lib/xine-lib-1_rc5-r2.ebuild9
3 files changed, 15 insertions, 13 deletions
diff --git a/media-libs/xine-lib/Manifest b/media-libs/xine-lib/Manifest
index 7cb75e16cb79..18a4c92edcf6 100644
--- a/media-libs/xine-lib/Manifest
+++ b/media-libs/xine-lib/Manifest
@@ -6,9 +6,9 @@ MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
MD5 3d849500b17b5ad075102cf70d75b7c4 xine-lib-0.9.13-r3.ebuild 3354
MD5 c639cbd78aac77ed3cff247df68d2608 xine-lib-1_rc2.ebuild 3934
MD5 21f16ff9e27523f78078b77e1bd41c54 xine-lib-1_rc3-r1.ebuild 4042
-MD5 1f3f5280a9f3cf03b49587b108d27545 xine-lib-1_rc4-r1.ebuild 4956
+MD5 e27462c202ed742fc5e3eabc05295127 xine-lib-1_rc4-r1.ebuild 4816
MD5 342f5acc8a2e99672e90f384dc6abf8e xine-lib-1_rc4.ebuild 4462
-MD5 98ac6f43c9976f277e45eb710c0d6848 xine-lib-1_rc5-r2.ebuild 4961
+MD5 e32947e122d9fc05e9af48ae1638ba38 xine-lib-1_rc5-r2.ebuild 4821
MD5 f1570a69c99207f65b5cdf1d154bbcd4 files/digest-xine-lib-0.9.13-r3 68
MD5 f90bfe4a0ee80eecb38fc34022ccab7e files/digest-xine-lib-1_rc2 67
MD5 5e99bec89f5cc4f0d00bcd61430d67cb files/protect-CFLAGS.patch-1_rc2 597
@@ -37,7 +37,7 @@ MD5 e87a4ce6246db7db0d3cf0d967cb62d2 files/protect-CFLAGS.patch-1_rc5-r2 641
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.8 (GNU/Linux)
-iD8DBQFA4b47HTu7gpaalycRAvNwAKDB47+trGHn6TivUzuj32pwTKckGQCfUqm/
-nmTw1M091GpP7NzOBpuOJAI=
-=9aYt
+iD8DBQFA4cErHTu7gpaalycRAhUgAJ9YqgcZcnFHQxIcW2h4AR0JVY9bRgCggnrL
+Oyo5acwm2EY/RlHpbGeN1Gc=
+=bOYB
-----END PGP SIGNATURE-----
diff --git a/media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild b/media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild
index a323d8eee106..d17cf7e605f5 100644
--- a/media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild,v 1.15 2004/06/29 19:08:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc4-r1.ebuild,v 1.16 2004/06/29 19:20:52 vapier Exp $
inherit eutils flag-o-matic gcc libtool
@@ -89,9 +89,10 @@ src_compile() {
# fix build errors with sse2 #49482
if use x86 ; then
- [ "`gcc-version`" == "3.2" ] && append-flags -mno-sse2 && filter-mfpmath sse
- [ "`gcc-version`" == "3.3" ] && append-flags -mno-sse2 -mno-sse3 && filter-mfpmath sse
- [ "`gcc-version`" == "3.4" ] && append-flags -mno-sse2 -mno-sse3 && filter-mfpmath sse
+ if [ `gcc-major-version` -eq 3 ] ; then
+ append-flags -mno-sse2 `test_flag -mno-sse3`
+ filter-mfpmath sse
+ fi
fi
# Use the built-in dvdnav plugin.
diff --git a/media-libs/xine-lib/xine-lib-1_rc5-r2.ebuild b/media-libs/xine-lib/xine-lib-1_rc5-r2.ebuild
index 6538c632f6d7..4d810dafb199 100644
--- a/media-libs/xine-lib/xine-lib-1_rc5-r2.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_rc5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc5-r2.ebuild,v 1.2 2004/06/29 19:08:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc5-r2.ebuild,v 1.3 2004/06/29 19:20:52 vapier Exp $
inherit eutils flag-o-matic gcc libtool
@@ -89,9 +89,10 @@ src_compile() {
# fix build errors with sse2 #49482
if use x86 ; then
- [ "`gcc-version`" == "3.2" ] && append-flags -mno-sse2 && filter-mfpmath sse
- [ "`gcc-version`" == "3.3" ] && append-flags -mno-sse2 -mno-sse3 && filter-mfpmath sse
- [ "`gcc-version`" == "3.4" ] && append-flags -mno-sse2 -mno-sse3 && filter-mfpmath sse
+ if [ `gcc-major-version` -eq 3 ] ; then
+ append-flags -mno-sse2 `test_flag -mno-sse3`
+ filter-mfpmath sse
+ fi
fi
# Use the built-in dvdnav plugin.