summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-01-27 13:46:55 +0000
committerChristoph Mende <angelos@gentoo.org>2008-01-27 13:46:55 +0000
commitca005dd1769fbc644904fb6f125867d139321237 (patch)
tree9fa53aae1d7d736a328dca57a69f11dce7f1e443 /media-plugins/gmpc-lastfm
parentAdd Pavel and me as his proxy to metadata (diff)
downloadhistorical-ca005dd1769fbc644904fb6f125867d139321237.tar.gz
historical-ca005dd1769fbc644904fb6f125867d139321237.tar.bz2
historical-ca005dd1769fbc644904fb6f125867d139321237.zip
Taking over maintainership and version bump (Bug #202995 by Jesse Adelman)
Package-Manager: portage-2.1.4
Diffstat (limited to 'media-plugins/gmpc-lastfm')
-rw-r--r--media-plugins/gmpc-lastfm/ChangeLog10
-rw-r--r--media-plugins/gmpc-lastfm/files/digest-gmpc-lastfm-0.15.5.03
-rw-r--r--media-plugins/gmpc-lastfm/gmpc-lastfm-0.15.5.0.ebuild36
3 files changed, 47 insertions, 2 deletions
diff --git a/media-plugins/gmpc-lastfm/ChangeLog b/media-plugins/gmpc-lastfm/ChangeLog
index a608182fe8b9..27629fa829b5 100644
--- a/media-plugins/gmpc-lastfm/ChangeLog
+++ b/media-plugins/gmpc-lastfm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/gmpc-lastfm
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-lastfm/ChangeLog,v 1.7 2007/08/07 15:55:44 gustavoz Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-lastfm/ChangeLog,v 1.8 2008/01/27 13:34:07 angelos Exp $
+
+*gmpc-lastfm-0.15.5.0 (27 Jan 2008)
+
+ 27 Jan 2008; Christoph Mende <angelos@gentoo.org>
+ +gmpc-lastfm-0.15.5.0.ebuild:
+ Taking over maintainership and version bump (Bug #202995 by Jesse Adelman)
07 Aug 2007; Gustavo Zacarias <gustavoz@gentoo.org>
gmpc-lastfm-0.15.0.ebuild:
diff --git a/media-plugins/gmpc-lastfm/files/digest-gmpc-lastfm-0.15.5.0 b/media-plugins/gmpc-lastfm/files/digest-gmpc-lastfm-0.15.5.0
new file mode 100644
index 000000000000..2274ec38aa4d
--- /dev/null
+++ b/media-plugins/gmpc-lastfm/files/digest-gmpc-lastfm-0.15.5.0
@@ -0,0 +1,3 @@
+MD5 7e5833ef6689a8aed9fee9f5d6be3043 gmpc-last.fm-0.15.5.0.tar.gz 313229
+RMD160 8532216d70cc49b6d5a41d3e6e4854c90f231a38 gmpc-last.fm-0.15.5.0.tar.gz 313229
+SHA256 e10afc631e379a99013d8e6894c404368a638ff1ba390bd6bcc642beab1fd3f5 gmpc-last.fm-0.15.5.0.tar.gz 313229
diff --git a/media-plugins/gmpc-lastfm/gmpc-lastfm-0.15.5.0.ebuild b/media-plugins/gmpc-lastfm/gmpc-lastfm-0.15.5.0.ebuild
new file mode 100644
index 000000000000..465a50397de4
--- /dev/null
+++ b/media-plugins/gmpc-lastfm/gmpc-lastfm-0.15.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-lastfm/gmpc-lastfm-0.15.5.0.ebuild,v 1.1 2008/01/27 13:34:07 angelos Exp $
+
+inherit eutils
+
+MY_PN="gmpc-last.fm"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="This plugin fetches artist art from last.fm"
+HOMEPAGE="http://sarine.nl/gmpc-plugins-lastfm"
+SRC_URI="http://download.sarine.nl/gmpc-0.15.5/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-sound/gmpc-${PV}
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! built_with_use =x11-libs/gtk+-2* jpeg ; then
+ echo
+ eerror "x11-libs/gtk+-2 needs to be built with \"jpeg\" USE flag"
+ die "x11-libs/gtk+-2 needs to be built with \"jpeg\" USE flag"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+}