summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2009-02-23 23:50:41 +0000
committerJoerg Bornkessel <hd_brummy@gentoo.org>2009-02-23 23:50:41 +0000
commita4004b610d4b8fd49db648828c53df69886df0b4 (patch)
tree5c872c4089745ea5d9def2a79b1ff9da8c09a5b8 /media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild
parentmake eclass ready for eapi2 (diff)
downloadhistorical-a4004b610d4b8fd49db648828c53df69886df0b4.tar.gz
historical-a4004b610d4b8fd49db648828c53df69886df0b4.tar.bz2
historical-a4004b610d4b8fd49db648828c53df69886df0b4.zip
fixed gettext support, fixed compile for distcc, multicore support
Package-Manager: portage-2.1.6.7/cvs/Linux i686
Diffstat (limited to 'media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild')
-rw-r--r--media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild b/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..86069607e1ad
--- /dev/null
+++ b/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild,v 1.1 2009/02/23 23:50:41 hd_brummy Exp $
+
+inherit vdr-plugin
+
+DESCRIPTION="VDR plugin: edit Autotimers of XXV via VDR on-screen-display"
+HOMEPAGE="http://www.vdrtools.de/vdrxxvautotimer.html"
+SRC_URI="http://www.vdrtools.de/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.3.0"
+
+RDEPEND=">=net-www/xxv-0.30"
+
+PATCHES=("${FILESDIR}/vdr-1.5.7-gettext.diff"
+ "${FILESDIR}/${P}_gcc-4.3.x.diff"
+ "${FILESDIR}/${P}_compile-warn.diff"
+ "${FILESDIR}/${P}-makefile-fix.diff")
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ sed -i "s:CFLAGS =:CFLAGS ?=:" "${S}"/mysqlwrapped-1.4/Makefile
+}