summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-02-09 19:47:46 +0000
committerAron Griffis <agriffis@gentoo.org>2004-02-09 19:47:46 +0000
commit714f29b41cdf1a14c96352c70a1a2203f9c3ac1d (patch)
treed27cee60591622532071fc3b1e8095920cf54696 /media-plugins/xmms-cdread
parentuse ? -> use? (diff)
downloadhistorical-714f29b41cdf1a14c96352c70a1a2203f9c3ac1d.tar.gz
historical-714f29b41cdf1a14c96352c70a1a2203f9c3ac1d.tar.bz2
historical-714f29b41cdf1a14c96352c70a1a2203f9c3ac1d.zip
Apply the endian patch to all arches since it's ifdef'd anyway. Add ~alpha and ~ia64
Diffstat (limited to 'media-plugins/xmms-cdread')
-rw-r--r--media-plugins/xmms-cdread/ChangeLog9
-rw-r--r--media-plugins/xmms-cdread/Manifest6
-rw-r--r--media-plugins/xmms-cdread/files/endian.patch4
-rw-r--r--media-plugins/xmms-cdread/xmms-cdread-0.14a-r1.ebuild22
4 files changed, 27 insertions, 14 deletions
diff --git a/media-plugins/xmms-cdread/ChangeLog b/media-plugins/xmms-cdread/ChangeLog
index b18d56df80cd..77b596aa8993 100644
--- a/media-plugins/xmms-cdread/ChangeLog
+++ b/media-plugins/xmms-cdread/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/xmms-cdread
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdread/ChangeLog,v 1.4 2003/10/29 23:49:18 lu_zero Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdread/ChangeLog,v 1.5 2004/02/09 19:47:46 agriffis Exp $
+
+ 07 Feb 2004; Aron Griffis <agriffis@gentoo.org> xmms-cdread-0.14a-r1.ebuild,
+ files/endian.patch:
+ Apply the endian patch to all arches since it's ifdef'd anyway. Add ~alpha and
+ ~ia64
30 Oct 2003 Luca Barbato <lu_zero@gentoo.org> :
Added a patch to fix an endianess issue thanks to KruzeS <kruzes@sapo.pt>
diff --git a/media-plugins/xmms-cdread/Manifest b/media-plugins/xmms-cdread/Manifest
index 891cb336bff9..754f3789a529 100644
--- a/media-plugins/xmms-cdread/Manifest
+++ b/media-plugins/xmms-cdread/Manifest
@@ -1,7 +1,7 @@
-MD5 897cfec6c8eaea8da1f0ea3787d9b072 ChangeLog 974
+MD5 ee8105636a5f53763464afc9c12e4fdf ChangeLog 1166
MD5 0d733e467605769ed4ec0761d77903f1 xmms-cdread-0.14a.ebuild 606
-MD5 c277a580234e4545d1f5967004b79131 xmms-cdread-0.14a-r1.ebuild 749
+MD5 f53272cb65d5979717cc8829b4c0cf08 xmms-cdread-0.14a-r1.ebuild 993
MD5 41770b01760e5e215a7649781e3645ce files/digest-xmms-cdread-0.14a 69
-MD5 0e1d2daff21584e0a3f95091dea29085 files/endian.patch 933
+MD5 ec795dadb3aa7147e8cb97de01fc67b1 files/endian.patch 962
MD5 41770b01760e5e215a7649781e3645ce files/digest-xmms-cdread-0.14a-r1 69
MD5 cb6038b1520b8423427d76ee312cff3a files/xmms-cdread-0.14a-xmms-1.2.8.patch 486
diff --git a/media-plugins/xmms-cdread/files/endian.patch b/media-plugins/xmms-cdread/files/endian.patch
index 68c2f2d7ae62..63c132366349 100644
--- a/media-plugins/xmms-cdread/files/endian.patch
+++ b/media-plugins/xmms-cdread/files/endian.patch
@@ -9,11 +9,13 @@ diff -Naur xmms-cdread-0.14a/filter.c xmms-cdread-0.14a-endian/filter.c
typedef double real;
-@@ -37,9 +38,16 @@
+@@ -37,9 +38,18 @@
int i, j, k;
sample *data = buf;
real ol, or;
++#ifdef __BIG_ENDIAN
+ char *p;
++#endif
if (!cd_eq_on) return;
diff --git a/media-plugins/xmms-cdread/xmms-cdread-0.14a-r1.ebuild b/media-plugins/xmms-cdread/xmms-cdread-0.14a-r1.ebuild
index 5bf3377c36c1..3f513b628225 100644
--- a/media-plugins/xmms-cdread/xmms-cdread-0.14a-r1.ebuild
+++ b/media-plugins/xmms-cdread/xmms-cdread-0.14a-r1.ebuild
@@ -1,24 +1,30 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdread/xmms-cdread-0.14a-r1.ebuild,v 1.3 2003/10/29 23:49:18 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdread/xmms-cdread-0.14a-r1.ebuild,v 1.4 2004/02/09 19:47:46 agriffis Exp $
+
+inherit gnuconfig
-S=${WORKDIR}/${P}
DESCRIPTION="XMMS plugin to read audio cdroms as data"
HOMEPAGE="ftp://mud.stack.nl/pub/OuterSpace/willem/"
SRC_URI="ftp://mud.stack.nl/pub/OuterSpace/willem/${P}.tar.gz"
-
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~x86 ~ppc ~alpha ~ia64"
DEPEND=">=media-sound/xmms-1.2.8"
src_unpack () {
- unpack ${A}
+ unpack ${A} && cd ${S} || die
- cd ${S}
+ # Patch to make this plugin compatible with xmms-1.2.8
epatch ${FILESDIR}/${P}-xmms-1.2.8.patch
- use ppc && epatch ${FILESDIR}/endian.patch
+
+ # The following patch is particularly for ppc but should apply
+ # cleanly for all arches (it's #ifdef'd inside the patch)
+ epatch ${FILESDIR}/endian.patch
+
+ # Recognize newer arches
+ gnuconfig_update || die
}
src_install () {