summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-12-15 12:27:57 +0000
committerPeter Volkov <pva@gentoo.org>2008-12-15 12:27:57 +0000
commitc0ca2d70a25af174236aebc2c0a92b0b9c59b896 (patch)
tree15fbd474e788ba6984ff310fb54068d7581a36a0 /media-radio/svxlink/files
parentUnmasking spandsp as upstream told us to use >=spandsp-0.0.6_pre2. Fix packag... (diff)
downloadhistorical-c0ca2d70a25af174236aebc2c0a92b0b9c59b896.tar.gz
historical-c0ca2d70a25af174236aebc2c0a92b0b9c59b896.tar.bz2
historical-c0ca2d70a25af174236aebc2c0a92b0b9c59b896.zip
Fixed build problem with >=spandsp-0.0.6_pre2, bug #249338, thank Yaroslav Gorbunov for report and patch. Fixed build issue with --as-needed, bug #247807, thank Diego E. 'Flameeyes' Pettenò for report. Force to use up-to-date spandsp library.
Package-Manager: portage-2.2_rc17/cvs/Linux 2.6.26-openvz.git-89451f9 i686
Diffstat (limited to 'media-radio/svxlink/files')
-rw-r--r--media-radio/svxlink/files/svxlink-080730--as-needed.patch13
-rw-r--r--media-radio/svxlink/files/svxlink-080730-spandsp-0.0.6_pre2.patch21
2 files changed, 34 insertions, 0 deletions
diff --git a/media-radio/svxlink/files/svxlink-080730--as-needed.patch b/media-radio/svxlink/files/svxlink-080730--as-needed.patch
new file mode 100644
index 000000000000..c6ca9d9c4fc5
--- /dev/null
+++ b/media-radio/svxlink/files/svxlink-080730--as-needed.patch
@@ -0,0 +1,13 @@
+=== modified file 'async/demo/Makefile.default'
+--- async/demo/Makefile.default 2008-11-30 12:25:03 +0000
++++ async/demo/Makefile.default 2008-11-30 12:34:18 +0000
+@@ -62,7 +62,7 @@
+ PRGSRC =
+
+ # Libraries compiled in the project (in $(LIB)).
+-PROJLIBS = -lasynccpp -lasyncaudio
++PROJLIBS = -lasynccpp -lasyncaudio -lasynccore
+ ifdef QT_BIN
+ PROJLIBS += -lasyncqt
+ endif
+
diff --git a/media-radio/svxlink/files/svxlink-080730-spandsp-0.0.6_pre2.patch b/media-radio/svxlink/files/svxlink-080730-spandsp-0.0.6_pre2.patch
new file mode 100644
index 000000000000..8a248dec4436
--- /dev/null
+++ b/media-radio/svxlink/files/svxlink-080730-spandsp-0.0.6_pre2.patch
@@ -0,0 +1,21 @@
+=== modified file 'svxlink/trx/SpanDtmfDecoder.cpp'
+--- svxlink/trx/SpanDtmfDecoder.cpp 2008-12-07 18:35:58 +0000
++++ svxlink/trx/SpanDtmfDecoder.cpp 2008-12-07 18:38:37 +0000
+@@ -40,6 +40,7 @@
+ #include <stdlib.h>
+ #include <stdint.h>
+ #include <spandsp.h>
++#include <spandsp/expose.h>
+
+
+ /****************************************************************************
+@@ -166,7 +167,7 @@
+ }
+
+ dtmf_rx_init(&p->rx_state, NULL, this);
+- dtmf_rx_parms(&p->rx_state, FALSE, max_fwd_twist, max_rev_twist);
++ dtmf_rx_parms(&p->rx_state, FALSE, max_fwd_twist, max_rev_twist, -99);
+ dtmf_rx_set_realtime_callback(&p->rx_state, SpanDtmfDecoder::toneReportCb,
+ this);
+
+