summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-02-09 12:32:20 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-02-09 12:32:20 +0000
commitd311223d7fa216d12c42266ae6c7a8a4cac32644 (patch)
tree66c7d8b2de0b76f32e90eda31b3920a933a1cd49 /media-sound/abcde/abcde-1.9.9-r1.ebuild
parentinitial ebuild, with SLOT (diff)
downloadhistorical-d311223d7fa216d12c42266ae6c7a8a4cac32644.tar.gz
historical-d311223d7fa216d12c42266ae6c7a8a4cac32644.tar.bz2
historical-d311223d7fa216d12c42266ae6c7a8a4cac32644.zip
new revision of abcde, closed bug #397, added SLOT var
Diffstat (limited to 'media-sound/abcde/abcde-1.9.9-r1.ebuild')
-rw-r--r--media-sound/abcde/abcde-1.9.9-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/abcde/abcde-1.9.9-r1.ebuild b/media-sound/abcde/abcde-1.9.9-r1.ebuild
new file mode 100644
index 000000000000..9726a82d7897
--- /dev/null
+++ b/media-sound/abcde/abcde-1.9.9-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcde/abcde-1.9.9-r1.ebuild,v 1.1 2002/02/09 12:32:20 verwilst Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="a better cd encoder"
+SRC_URI="http://lly.org/~rcw/abcde/development/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://lly.org/~rcw/abcde/page/"
+SLOT="0"
+DEPEND=">=media-sound/id3-0.12
+ >=media-sound/cd-discid-0.6
+ >=media-sound/cdparanoia-3.9.7
+ >=media-sound/vorbis-tools-1.0_rc3"
+
+src_unpack() {
+
+ unpack ${PN}_${PV}.orig.tar.gz
+ cd ${S}
+ cp Makefile Makefile.orig
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_install () {
+ cd ${S}
+ dodir /etc/abcde
+ make DESTDIR=${D} install || die
+ dodoc COPYING README TODO changelog
+}
+