summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-01-27 19:10:25 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-01-27 19:10:25 +0000
commit68d35068cf44ba13c9b02342ec875380ad3a763c (patch)
treec59767580fd8af9f3b3601ab6f3562dd45631749 /media-sound/alsa-driver
parentVersion bumped. (diff)
downloadhistorical-68d35068cf44ba13c9b02342ec875380ad3a763c.tar.gz
historical-68d35068cf44ba13c9b02342ec875380ad3a763c.tar.bz2
historical-68d35068cf44ba13c9b02342ec875380ad3a763c.zip
Version bumped.
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/Manifest4
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.2.ebuild91
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.21
3 files changed, 94 insertions, 2 deletions
diff --git a/media-sound/alsa-driver/Manifest b/media-sound/alsa-driver/Manifest
index 6ff57412ad9f..0d7567770f5a 100644
--- a/media-sound/alsa-driver/Manifest
+++ b/media-sound/alsa-driver/Manifest
@@ -1,9 +1,9 @@
-MD5 80ea879b293ea64adad93459aca3b337 ChangeLog 11712
+MD5 a323e65fdeb88df83ecdfb228a944fb4 ChangeLog 11837
MD5 818724de762b3a6f42600d4daab66cb5 alsa-driver-0.5.12a.ebuild 1669
MD5 6c59545084b1b0fa4d85a1fb33fb9df6 alsa-driver-0.9.0_rc2.ebuild 2659
MD5 13c7a09a248e6ba5fc7aa5f7442167c2 alsa-driver-0.9.2.ebuild 2690
MD5 401b1e7b11d5cfd408421f25cc4b0a88 alsa-driver-0.9.8.ebuild 2213
-MD5 bc2b59b022427daa32d85474f11df9f5 alsa-driver-1.0.2.ebuild 2441
+MD5 a3a2cfa9d9ab95b85c8ec68ebfb125e3 alsa-driver-1.0.2.ebuild 2443
MD5 3ef978d6f5424df9058c204e249409a1 alsa-driver-1.0.0_rc2.ebuild 2439
MD5 e1147a642867b3b3ea43518a1376f6d2 metadata.xml 250
MD5 bc2b59b022427daa32d85474f11df9f5 alsa-driver-1.0.1.ebuild 2441
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.2.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.2.ebuild
new file mode 100644
index 000000000000..4004a85a41a0
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-1.0.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.2.ebuild,v 1.1 2004/01/27 19:10:07 mholzer Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+LICENSE="GPL-2 LGPL-2.1"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment to a space-separated list of drivers that you want to build.
+# For example:
+#
+# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+#
+[ x"${ALSA_CARDS}" = x ] && ALSA_CARDS=all
+
+IUSE="oss"
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ virtual/linux-sources
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+PROVIDE="virtual/alsa"
+
+SLOT="${KV}"
+KEYWORDS="~x86 ~ppc -sparc ~amd64"
+
+MY_P=${P/_rc/rc}
+#SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${MY_P}.tar.bz2"
+SRC_URI="mirror://alsaproject/driver/${P}.tar.bz2"
+RESTRICT="nomirror"
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ ewarn "This does not work with kernel 2.6 !!!"
+ ewarn "Please use the kernel modules instead of this the package"
+ # The makefile still installs an alsasound initscript,
+ # which we REALLY dont want.
+ # This patch stops that
+ epatch ${FILESDIR}/makefile.patch || die "Makefile patch failed"
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+
+ myconf=""
+ use oss && myconf="$myconf --with-oss=yes" || \
+ myconf="$myconf --with-oss=no"
+
+ ./configure \
+ $myconf \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-cards="${ALSA_CARDS}" \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+
+src_install() {
+ dodir /usr/include/sound
+ make DESTDIR=${D} install || die
+
+ rm doc/Makefile
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use the 'alsamixer' program to unmute them."
+ einfo
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.2 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.2
new file mode 100644
index 000000000000..b33f7f1f80fb
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.2
@@ -0,0 +1 @@
+MD5 75d652cc70d26d26720a9b2739b0ffa5 alsa-driver-1.0.2.tar.bz2 1674553