summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2003-09-04 08:58:06 +0000
committerJohn Mylchreest <johnm@gentoo.org>2003-09-04 08:58:06 +0000
commit8d06072900961e20dd3406cc989b28c97cbd0d09 (patch)
tree080757ac479451a72a6d2e7c1d591cb5fb6ec592 /media-sound/alsa-utils
parentwhitespace cleanup (diff)
downloadhistorical-8d06072900961e20dd3406cc989b28c97cbd0d09.tar.gz
historical-8d06072900961e20dd3406cc989b28c97cbd0d09.tar.bz2
historical-8d06072900961e20dd3406cc989b28c97cbd0d09.zip
Updating init script to load all oss compat modules. not just pcm-oss
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/ChangeLog5
-rw-r--r--media-sound/alsa-utils/Manifest4
-rw-r--r--media-sound/alsa-utils/files/alsasound10
3 files changed, 13 insertions, 6 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index b60829b92a77..1813a35e9c99 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.28 2003/08/21 18:17:50 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.29 2003/09/04 08:57:57 johnm Exp $
+
+ 04 Sep 2003; John Mylchreest <johnm@gentoo.org>; files/alsasound:
+ Updating init script to load all oss compat modules. not just pcm-oss
21 Aug 2003; John Mylchreest <johnm@gentoo.org>; files/alsasound:
Updating alsasound to load sequencers properly
diff --git a/media-sound/alsa-utils/Manifest b/media-sound/alsa-utils/Manifest
index e9eea77d01c8..a2e7c992aecf 100644
--- a/media-sound/alsa-utils/Manifest
+++ b/media-sound/alsa-utils/Manifest
@@ -6,7 +6,7 @@ MD5 3fcdc38c3c2fe679b64f7081a247d5cc alsa-utils-0.9.6-r1.ebuild 1856
MD5 165b9cf816fcb254f612d588cc9ade69 alsa-utils-0.9.3.ebuild 902
MD5 b268f1eb52b27b8146ddf58e76c55d4f alsa-utils-0.5.10-r8.ebuild 970
MD5 033eb6f293062de1cee097ccc42c414c alsa-utils-0.9.5.ebuild 901
-MD5 8c488c1c69c4d8fb3046a33781915816 ChangeLog 4868
+MD5 bcc1be4d3b7751064e2838d6dc9f2a6c ChangeLog 5009
MD5 c812f148a9d4ed6c2ef55942997ab3ab files/digest-alsa-utils-0.9.6-r1 69
MD5 f8aff370f9c369682ac793f5b3f4886e files/alsa-modules.conf-rc 1158
MD5 59a93bf64737644e4001cbb6ad5387b4 files/digest-alsa-utils-0.9.0_rc2 71
@@ -20,4 +20,4 @@ MD5 dcc66ee6a9db24006a4158e2be0da3f2 files/alsa-0.5.10 392
MD5 a82c4c173c1d617bae9967438c659bac files/digest-alsa-utils-0.5.10-r8 70
MD5 332df836790d7158bf4bbcf3b1a650c1 files/alsa.rc5 444
MD5 387a6bdfd1b85aff55902bf1a7d7d19e files/alsa.rc6 632
-MD5 6a14469863782186150eb7567383c511 files/alsasound 4596
+MD5 972a608198cbc953684e6f36a41604b7 files/alsasound 4653
diff --git a/media-sound/alsa-utils/files/alsasound b/media-sound/alsa-utils/files/alsasound
index dd248783addf..64323c22d0c5 100644
--- a/media-sound/alsa-utils/files/alsasound
+++ b/media-sound/alsa-utils/files/alsasound
@@ -1,5 +1,5 @@
#!/sbin/runscript
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsasound,v 1.2 2003/08/21 18:17:50 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsasound,v 1.3 2003/09/04 08:57:57 johnm Exp $
#
# Gentoo users: add this script to 'boot' run level.
# ==================================================
@@ -52,14 +52,18 @@ start() {
# I really dislike this and would like to tidy it up.
# Anyone running 2.4 + alsa-driver willing to help me?
- DRIVERS="$(modprobe -c | grep snd_ | grep pci: | awk '{ print $3 }' | uniq)"
+ DRIVERS="$(modprobe -c | grep snd.* | grep pci: | awk '{ print $3 }' | uniq)"
if [ -z "${DRIVERS}" ] ; then
# Fallback on older modprobe syntax
DRIVERS="$(/sbin/modprobe -c | grep -E "^[[:space:]]*alias[[:space:]]+snd-card-[[:digit:]]" | awk '{print $3}')"
fi
[ -z "${DRIVERS}" ] && eerror "Unable to find any ALSA drivers. Have you compiled alsa-drivers correctly?"
- [ -n "$(modprobe -l | grep "snd.*oss")" ] && DRIVERS="snd-pcm-oss ${DRIVERS}"
+ OSS="$(modprobe -l | grep "snd.*oss" | sed -e "s:\/.*\/::" -e "s:\..*::")"
+ for i in ${OSS}
+ do
+ DRIVERS="${i} ${DRIVERS}"
+ done
for DRIVER in ${DRIVERS}
do