summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-17 09:47:37 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-17 09:47:37 +0000
commit21e6f932aecac6908f831747bcb40d760ef2f70e (patch)
treec76072a02e4f9cc502e7fd75fc6e0f5aa40b8455 /media-sound/aumix
parentRevision bump - this version of transcode should work flawlessy with mplayer. (diff)
downloadhistorical-21e6f932aecac6908f831747bcb40d760ef2f70e.tar.gz
historical-21e6f932aecac6908f831747bcb40d760ef2f70e.tar.bz2
historical-21e6f932aecac6908f831747bcb40d760ef2f70e.zip
Changed mkdir ${D} to dodir ${D}
Diffstat (limited to 'media-sound/aumix')
-rw-r--r--media-sound/aumix/aumix-2.7-r4.ebuild22
1 files changed, 5 insertions, 17 deletions
diff --git a/media-sound/aumix/aumix-2.7-r4.ebuild b/media-sound/aumix/aumix-2.7-r4.ebuild
index 290d389b394c..1431f6787c9e 100644
--- a/media-sound/aumix/aumix-2.7-r4.ebuild
+++ b/media-sound/aumix/aumix-2.7-r4.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/aumix-2.7-r4.ebuild,v 1.10 2002/11/14 21:58:42 wwoods Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/aumix-2.7-r4.ebuild,v 1.11 2002/11/17 09:43:02 vapier Exp $
-IUSE="gpm nls gtk gnome alsa"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Aumix volume/mixer control program."
SRC_URI="http://jpj.net/~trevor/aumix/${P}.tar.gz"
HOMEPAGE="http://jpj.net/~trevor/aumix/"
@@ -12,6 +9,7 @@ HOMEPAGE="http://jpj.net/~trevor/aumix/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64 ~alpha"
+IUSE="gpm nls gtk gnome alsa"
DEPEND=">=sys-libs/ncurses-5.2
gpm? ( >=sys-libs/gpm-1.19.3 )
@@ -19,38 +17,28 @@ DEPEND=">=sys-libs/ncurses-5.2
gtk? ( =x11-libs/gtk+-1.2* )
nls? ( sys-devel/gettext )"
-
src_compile() {
-
local myconf
use gpm || myconf="--without-gpm"
use nls || myconf="--disable-nls"
use gtk || myconf="$myconf --without-gtk"
use alsa || myconf="$myconf --without-alsa"
- ./configure \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/man \
- --host=${CHOST} \
- $myconf || die "./configure failed"
-
+ econf ${myconf}
emake || die "make failed"
}
src_install() {
-
- make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
dodoc AUTHORS BUGS COPYING ChangeLog NEWS README TODO
if use gnome; then
insinto /usr/share/gnome/apps/Multimedia
doins ${FILESDIR}/aumix.desktop
- mkdir -p ${D}/usr/share/pixmaps
+ dodir /usr/share/pixmaps
ln -s ../aumix/aumix.xpm ${D}/usr/share/pixmaps
fi
exeinto /etc/init.d ; newexe ${FILESDIR}/aumix.rc6 aumix
}
-