summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Eichert <viz@gentoo.org>2003-01-29 14:39:01 +0000
committerTobias Eichert <viz@gentoo.org>2003-01-29 14:39:01 +0000
commit280f66dc3961d42499ce941887af76b260e47eee (patch)
tree7d8aba34983df4b34b8bbd67bee4109225c6bbd6 /media-sound/ecasound
parentNew version for KDE-3.1 (diff)
downloadhistorical-280f66dc3961d42499ce941887af76b260e47eee.tar.gz
historical-280f66dc3961d42499ce941887af76b260e47eee.tar.bz2
historical-280f66dc3961d42499ce941887af76b260e47eee.zip
version bump.
Diffstat (limited to 'media-sound/ecasound')
-rw-r--r--media-sound/ecasound/ChangeLog9
-rw-r--r--media-sound/ecasound/ecasound-2.2.0.ebuild91
-rw-r--r--media-sound/ecasound/files/digest-ecasound-2.2.01
3 files changed, 100 insertions, 1 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
index 537d2d67c6b0..6faaa60db809 100644
--- a/media-sound/ecasound/ChangeLog
+++ b/media-sound/ecasound/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/ecasound-2.0.4.ebuild
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.3 2003/01/16 00:56:29 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.4 2003/01/29 14:39:01 viz Exp $
+
+*ecasound-2.2.0 (29 Jan 2003)
+
+ 29 Jan 2003; Tobias Eichert <viz@gentoo.org> ecasound-2.2.0.ebuild
+ files/digest-ecasound-2.2.0:
+
+ Version bump.
15 Jan 2003; Nick Hadaway <raker@gentoo.org> ecasound-2.2.0_rc1.ebuild :
changed jack depend to virtual/jack
diff --git a/media-sound/ecasound/ecasound-2.2.0.ebuild b/media-sound/ecasound/ecasound-2.2.0.ebuild
new file mode 100644
index 000000000000..133079b4dc07
--- /dev/null
+++ b/media-sound/ecasound/ecasound-2.2.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.2.0.ebuild,v 1.1 2003/01/29 14:39:01 viz Exp $
+
+IUSE="ncurses arts alsa python oss libmikmod audiofile oggvorbis"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A package for multitrack audio processing"
+SRC_URI="http://ecasound.seul.org/download/${P}.tar.gz"
+HOMEPAGE="http://eca.cx/"
+LICENSE="GPL-2"
+
+SLOT="1"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ virtual/jack
+ media-libs/ladspa-sdk
+ alsa? ( media-libs/alsa-lib )
+ oggvorbis? ( media-libs/libvorbis )
+ arts? ( kde-base/arts )
+ audiofile? ( media-libs/audiofile )
+ libmikmod? ( media-libs/libmikmod )
+ python? ( dev-lang/python )
+ ncurses? ( sys-libs/ncurses )"
+
+# We don't make RDEPEND for vorbis-tools, mpg123/mpg321, timidity++ or lame -- no
+# use flags for them.
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ cp configure 1
+ sed -e 's:map.h:map:g' 1 > configure
+
+}
+
+src_compile () {
+ local myconf
+
+ use alsa || myconf="$myconf --disable-alsa"
+ use arts || myconf="$myconf --disable-arts"
+ use ncurses || myconf="$myconf --disable-ncurses"
+ use audiofile || myconf="$myconf --disable-audiofile"
+ use oss || myconf="$myconf --disable-oss"
+
+ if use python; then
+ #
+ # ecasound is braindead about finding python includes/libdirs and
+ # about where to install modules. Luckily, it allows us to specify
+ # all this.
+ #
+ local python_version python_prefix python_includes python_modules
+ python_version="`python -c 'import sys; print sys.version[:3]'`"
+ python_prefix="`python -c 'import sys; print sys.prefix'`"
+
+ python_includes="$python_prefix/include/python$python_version"
+ python_modules="$python_prefix/lib/python$python_version"
+
+ # ecasound configure assumes `disable' if you pass
+ # --(enable|disable)-pyecasound. *sigh*
+ #myconf="$myconf --enable-pyecasound"
+
+ myconf="$myconf --with-python-includes=$python_includes"
+ myconf="$myconf --with-python-modules=$python_modules"
+ else
+ myconf="$myconf --disable-pyecasound"
+ fi
+
+ einfo "configuring with ${myconf}"
+ econf ${myconf} || die "configure failed"
+ make || die "build failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ if use python; then
+ cd pyecasound || die
+ python -c "import compileall; compileall.compile_dir('.')" || die
+ python -O -c "import compileall; compileall.compile_dir('.')" || die
+ python_sitepkgsdir="`python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`"
+ install *.pyc *.pyo "${D}/${python_sitepkgsdir}"
+ cd ..
+ fi
+
+ dodoc INSTALL FAQ BUGS COPYING NEWS README TODO
+ dohtml `find Documentation -name "*.html"`
+ dodoc Documentation/edi-list.txt
+}
diff --git a/media-sound/ecasound/files/digest-ecasound-2.2.0 b/media-sound/ecasound/files/digest-ecasound-2.2.0
new file mode 100644
index 000000000000..0854ba968c7f
--- /dev/null
+++ b/media-sound/ecasound/files/digest-ecasound-2.2.0
@@ -0,0 +1 @@
+MD5 93279ca49281b0457dd38f89f0a67089 ecasound-2.2.0.tar.gz 899887