summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-23 13:44:25 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-23 13:44:25 +0000
commitd314eb79535de2577e72011f29266cdc02da661e (patch)
tree79b66cb31d0548936bc6f481902c903787ce725a /media-sound/lame
parentrevision upped, fixed symlink (and bug #1981) (diff)
downloadhistorical-d314eb79535de2577e72011f29266cdc02da661e.tar.gz
historical-d314eb79535de2577e72011f29266cdc02da661e.tar.bz2
historical-d314eb79535de2577e72011f29266cdc02da661e.zip
updated lame version
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog6
-rw-r--r--media-sound/lame/files/digest-lame-3.921
-rw-r--r--media-sound/lame/lame-3.92.ebuild67
3 files changed, 73 insertions, 1 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 3d87050dc255..2c987c32d195 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/lame
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.3 2002/04/06 13:44:35 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.4 2002/04/23 13:44:25 spider Exp $
+
+*lame-3.92 (23 Apr 2002)
+ 23 Apr 2002; Spider <spider@gentoo.org> lame-3.92.ebuild:
+ update new version, remove gcc3 fixes (in mainline now)
06 Apr 2002; Geert Bevin <gbevin@gentoo.org> lame-3.91.ebuild,
files/lame-3.91-gcc3.diff :
diff --git a/media-sound/lame/files/digest-lame-3.92 b/media-sound/lame/files/digest-lame-3.92
new file mode 100644
index 000000000000..b78e0c4d310a
--- /dev/null
+++ b/media-sound/lame/files/digest-lame-3.92
@@ -0,0 +1 @@
+MD5 4e1b83a7b08636d2ef43711e4c74d3a9 lame-3.92.tar.gz 970894
diff --git a/media-sound/lame/lame-3.92.ebuild b/media-sound/lame/lame-3.92.ebuild
new file mode 100644
index 000000000000..c542c24716ab
--- /dev/null
+++ b/media-sound/lame/lame-3.92.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.92.ebuild,v 1.1 2002/04/23 13:44:25 spider Exp $
+
+S=${WORKDIR}/lame-${PV}
+DESCRIPTION="LAME Ain't an Mp3 Encoder"
+SRC_URI="http://download.sourceforge.net/lame/${P}.tar.gz"
+HOMEPAGE="http://www.mp3dev.org/mp3/"
+
+DEPEND="virtual/glibc
+ dev-lang/nasm
+ >=sys-libs/ncurses-5.2
+ gtk? ( >=x11-libs/gtk+-1.2.10-r4 )"
+# oggvorbis? ( >=media-libs/libvorbis-1.0_rc3 )"
+# Oggvorbis support breaks with -rc3
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ gtk? ( >=x11-libs/gtk+-1.2.10-r4 )"
+# oggvorbis? ( >=media-libs/libvorbis-1.0_rc3 )"
+
+src_unpack() {
+ unpack ${A}
+# cd ${S}
+# patch -p1 < ${FILESDIR}/lame-3.91-gcc3.diff || die
+}
+
+src_compile() {
+
+ local myconf=""
+ if [ "`use oggvorbis`" ] ; then
+# myconf="--with-vorbis"
+ myconf="--without-vorbis"
+ else
+ myconf="--without-vorbis"
+ fi
+ if [ "`use gtk`" ] ; then
+ myconf="$myconf --enable-mp3x"
+ fi
+ if [ "$DEBUG" ] ; then
+ myconf="$myconf --enable-debug=yes"
+ else
+ myconf="$myconf --enable-debug=no"
+ fi
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-shared \
+ --enable-nasm \
+ --enable-mp3rtp \
+ --enable-extopt=full \
+ $myconf || die
+
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ pkghtmldir=${D}/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc API COPYING HACKING PRESETS.draft LICENSE README* TODO USAGE
+ dohtml -r ./
+}
+