summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-09-04 17:23:27 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-09-04 17:23:27 +0000
commit3a422e7b488f7009e8ee50d1bd29615a1455aee8 (patch)
tree3d61d199b7f3af358120ba029c19e1a16e439e72 /media-sound/leechcraft-hotstreams
parentUse system liberation-fonts for bug #433932. (diff)
downloadhistorical-3a422e7b488f7009e8ee50d1bd29615a1455aee8.tar.gz
historical-3a422e7b488f7009e8ee50d1bd29615a1455aee8.tar.bz2
historical-3a422e7b488f7009e8ee50d1bd29615a1455aee8.zip
Add media-sound/leechcraft-hotstreams, thanks to 0xd34df00d
Package-Manager: portage-2.2.0_alpha123/cvs/Linux x86_64
Diffstat (limited to 'media-sound/leechcraft-hotstreams')
-rw-r--r--media-sound/leechcraft-hotstreams/ChangeLog10
-rw-r--r--media-sound/leechcraft-hotstreams/Manifest3
-rw-r--r--media-sound/leechcraft-hotstreams/leechcraft-hotstreams-9999.ebuild34
-rw-r--r--media-sound/leechcraft-hotstreams/metadata.xml5
4 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/leechcraft-hotstreams/ChangeLog b/media-sound/leechcraft-hotstreams/ChangeLog
new file mode 100644
index 000000000000..337a72ff585c
--- /dev/null
+++ b/media-sound/leechcraft-hotstreams/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/leechcraft-hotstreams
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/leechcraft-hotstreams/ChangeLog,v 1.1 2012/09/04 17:23:27 pinkbyte Exp $
+
+*leechcraft-hotstreams-9999 (04 Sep 2012)
+
+ 04 Sep 2012; Sergey Popov <pinkbyte@gentoo.org>
+ +leechcraft-hotstreams-9999.ebuild, +metadata.xml:
+ Add media-sound/leechcraft-hotstreams, thanks to 0xd34df00d
+
diff --git a/media-sound/leechcraft-hotstreams/Manifest b/media-sound/leechcraft-hotstreams/Manifest
new file mode 100644
index 000000000000..705ed7ebd2a7
--- /dev/null
+++ b/media-sound/leechcraft-hotstreams/Manifest
@@ -0,0 +1,3 @@
+EBUILD leechcraft-hotstreams-9999.ebuild 940 SHA256 b86ec9499890fcbb2506315cfd9f3dd712560d7972d57ea515c783f8b9f2d736 SHA512 460f6f72b166ba437165788c8aef05c9ea20a5098c68c0a80926cbc02257a590d31b0aa798ff5ed9d1a0d2600cc75ab801837b80423b5252af6011654fae4873 WHIRLPOOL 29509e00b280072b35f4d046ed67195c3f64a6e785ae33e430434ab8432ae9dd97f305558cebab0ade2fa750bfa8f8c13b1b452dbb6de5e31a0d5f53c1987efe
+MISC ChangeLog 450 SHA256 7e6a2fc4e336c467bbb97776b84556b8e7f2f4ec2f0471d71831f60c3e45aea2 SHA512 f04ba43b0fe5bf7846ef994ed436c291e476989157c286842940ad605725513067a994d0ba53859c6ab79cf5d89f477620d93a5e9022bad1d168d665dcd97ddb WHIRLPOOL a38767489322e1d4a62497a26da37c5265039a47af7e5ec443d781f3b7dfc323a3e81685a990d3c8aec60bfe38ed7a37a38e33c337f1e3cd3bfd1450d36a8596
+MISC metadata.xml 163 SHA256 6a0d0860c0ffde9ec19aef76a6749e3ce856e5053724bff774b0f292c050f722 SHA512 d404f0c5485a5699479569044e7134f6a1f3bc38dcdd97f11197bc1aa285b3b6edfed538502ee4eac2de8db516acfe58181ad57f385326abbc3c64d007a895bb WHIRLPOOL 3c09570f4875fe939de670fab9f2589f2bbd066c1e51421deecd0f0eade0523d437dafc1f0ccf1a06a012adba6e4cb233ce3108b15e28687dc7775eccfa8a905
diff --git a/media-sound/leechcraft-hotstreams/leechcraft-hotstreams-9999.ebuild b/media-sound/leechcraft-hotstreams/leechcraft-hotstreams-9999.ebuild
new file mode 100644
index 000000000000..58112e5b1528
--- /dev/null
+++ b/media-sound/leechcraft-hotstreams/leechcraft-hotstreams-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/leechcraft-hotstreams/leechcraft-hotstreams-9999.ebuild,v 1.1 2012/09/04 17:23:27 pinkbyte Exp $
+
+EAPI="4"
+
+inherit eutils leechcraft toolchain-funcs
+
+DESCRIPTION="Provides some cool radio streams to music players like LMP"
+
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="~net-misc/leechcraft-core-${PV}
+ dev-libs/qjson"
+RDEPEND="${DEPEND}"
+
+# TODO: Maybe simplify this or add apropriate function to leechcraft eclass?
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
+ && die "Sorry, but gcc 4.6 or higher is required."
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=
+ if [[ ${PV} != 9999 ]]; then
+ mycmakeargs+= "-DLEECHCRAFT_VERSION=${PV}"
+ fi
+ cmake-utils_src_configure
+}
diff --git a/media-sound/leechcraft-hotstreams/metadata.xml b/media-sound/leechcraft-hotstreams/metadata.xml
new file mode 100644
index 000000000000..12f1722f7fcc
--- /dev/null
+++ b/media-sound/leechcraft-hotstreams/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>leechcraft</herd>
+</pkgmetadata>