summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-09-05 06:01:39 +0000
committerDonny Davies <woodchip@gentoo.org>2001-09-05 06:01:39 +0000
commit304c297cc0e85e4add0bf8033e693881f136704d (patch)
treeb99eb8dd91f7fba511d8cc4cdbb8389ee12b32d1 /media-sound/mp3blaster
parentNew rev of Portage (1.6.7) (diff)
downloadhistorical-304c297cc0e85e4add0bf8033e693881f136704d.tar.gz
historical-304c297cc0e85e4add0bf8033e693881f136704d.tar.bz2
historical-304c297cc0e85e4add0bf8033e693881f136704d.zip
added a new version; neat program
Diffstat (limited to 'media-sound/mp3blaster')
-rw-r--r--media-sound/mp3blaster/files/digest-mp3blaster-3.0_p81
-rw-r--r--media-sound/mp3blaster/mp3blaster-3.0_p8.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/mp3blaster/files/digest-mp3blaster-3.0_p8 b/media-sound/mp3blaster/files/digest-mp3blaster-3.0_p8
new file mode 100644
index 000000000000..6960810675cd
--- /dev/null
+++ b/media-sound/mp3blaster/files/digest-mp3blaster-3.0_p8
@@ -0,0 +1 @@
+MD5 ac8d30b18cfd7b67efe1a3847c62fe17 mp3blaster-3.0p8.tar.gz
diff --git a/media-sound/mp3blaster/mp3blaster-3.0_p8.ebuild b/media-sound/mp3blaster/mp3blaster-3.0_p8.ebuild
new file mode 100644
index 000000000000..46e498fa333f
--- /dev/null
+++ b/media-sound/mp3blaster/mp3blaster-3.0_p8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.0_p8.ebuild,v 1.1 2001/09/05 06:01:39 woodchip Exp $
+
+A=${PN}-3.0p8.tar.gz
+S=${WORKDIR}/${PN}-3.0p8
+DESCRIPTION="MP3 command line player"
+SRC_URI="ftp://mud.stack.nl/pub/mp3blaster/${A}"
+HOMEPAGE="http://www.stack.nl/~brama/mp3blaster"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nas? ( >=media-sound/nas-1.4.1 )
+ mysql? ( >=dev-db/mysql-3.23.36 )
+ vorbis? ( >=media-libs/libvorbis-1.0_beta1 )"
+
+src_compile() {
+ local myconf
+ use nas && myconf="${myconf} --with-nas"
+ use mysql && myconf="${myconf} --with-mysql"
+ use vorbis || myconf="${myconf} --without-oggvorbis"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} ${myconf} || die
+
+ if [ "`use nas`" ] ; then
+ cd src
+ sed -e "s:^INCLUDES =:INCLUDES = -I/usr/X11R6/include:" \
+ -e "s:^splay_LDADD =:splay_LDADD = \$(NAS_LIBS):" Makefile | cat > Makefile
+ cd ..
+ fi
+
+ # parallel make does not work
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc ANNOUNCE AUTHORS COPYING CREDITS ChangeLog FAQ NEWS README TODO
+}