summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-03-13 20:15:58 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-03-13 20:15:58 +0000
commitcb4bddfa8745cda0a8c965c4f882be929aab3c35 (patch)
tree90b6d8fa85851a5740f5ae5388ea8dbc396416de /media-sound/opmixer
parentcontiuing to fix my mistakes... kdebase-applnk is the package that should mov... (diff)
downloadhistorical-cb4bddfa8745cda0a8c965c4f882be929aab3c35.tar.gz
historical-cb4bddfa8745cda0a8c965c4f882be929aab3c35.tar.bz2
historical-cb4bddfa8745cda0a8c965c4f882be929aab3c35.zip
added patch for gcc3.4, fixes #77451
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'media-sound/opmixer')
-rw-r--r--media-sound/opmixer/ChangeLog8
-rw-r--r--media-sound/opmixer/Manifest15
-rw-r--r--media-sound/opmixer/files/0.75-gcc34.patch28
-rw-r--r--media-sound/opmixer/opmixer-0.75.ebuild21
4 files changed, 62 insertions, 10 deletions
diff --git a/media-sound/opmixer/ChangeLog b/media-sound/opmixer/ChangeLog
index 8459bb5e9cc7..27ce532ac27a 100644
--- a/media-sound/opmixer/ChangeLog
+++ b/media-sound/opmixer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/opmixer
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/opmixer/ChangeLog,v 1.9 2004/09/15 19:39:14 eradicator Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/opmixer/ChangeLog,v 1.10 2005/03/13 20:15:58 luckyduck Exp $
+
+ 13 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org> +files/0.75-gcc34.patch,
+ opmixer-0.75.ebuild:
+ added patch for gcc3.4, fixes #77451
15 Sep 2004; Jeremy Huddleston <eradicator@gentoo.org> opmixer-0.75.ebuild:
Stable sparc.
diff --git a/media-sound/opmixer/Manifest b/media-sound/opmixer/Manifest
index 7a44f9a12207..79dcc00501eb 100644
--- a/media-sound/opmixer/Manifest
+++ b/media-sound/opmixer/Manifest
@@ -1,4 +1,15 @@
-MD5 cec65d635e767a2c00040b79a5816f6f ChangeLog 961
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 0ac09fc4b6806d812d8450b729777308 opmixer-0.75.ebuild 1084
+MD5 b86cf77667c6351b524a2533ac35a4fd ChangeLog 1101
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
-MD5 daf7919e6958aa841c807ebcb411bfca opmixer-0.75.ebuild 928
+MD5 c84f0516671e975810adc32baf3ad8f3 files/0.75-gcc34.patch 1354
MD5 5c5aff3a5d8372e6a48046af97b6343c files/digest-opmixer-0.75 64
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFCNJ+H06ebR+OMO78RAt4xAJ9gJ5LHLJDFD5c5Asat9sEhX8U5uQCfbmzO
+IA7AoyvsrY9nH1ET8jELpr4=
+=/wEe
+-----END PGP SIGNATURE-----
diff --git a/media-sound/opmixer/files/0.75-gcc34.patch b/media-sound/opmixer/files/0.75-gcc34.patch
new file mode 100644
index 000000000000..f5f29debf0ae
--- /dev/null
+++ b/media-sound/opmixer/files/0.75-gcc34.patch
@@ -0,0 +1,28 @@
+diff -uprN ../opMixer-0.75.orig/src/gui.cc src/gui.cc
+--- ../opMixer-0.75.orig/src/gui.cc 2005-03-13 20:08:23.473296872 +0100
++++ src/gui.cc 2005-03-13 21:13:59.667904336 +0100
+@@ -184,9 +184,9 @@ MixerGUI::MixerGUI (char *device) :
+ scaletable = manage(new Table(3,myMixer.NumDevices(),false));
+ menubar = new MenuBar();
+ statusbar = manage(new Label(title));
+- scaleboxes= new (VScale *)[myMixer.NumDevices()];
+- adj = new (Adjustment *)[myMixer.NumDevices()];
+- mutebuttons = new (CheckButton *)[myMixer.NumDevices()];
++ scaleboxes= new VScale *[myMixer.NumDevices()];
++ adj = new Adjustment *[myMixer.NumDevices()];
++ mutebuttons = new CheckButton *[myMixer.NumDevices()];
+ //--- initialize some vars to avoid segfaults =P //
+ set_policy(0,0,0);
+ lastload=new char[3];
+diff -uprN ../opMixer-0.75.orig/src/ossmixer.cc src/ossmixer.cc
+--- ../opMixer-0.75.orig/src/ossmixer.cc 2005-03-13 20:08:23.473296872 +0100
++++ src/ossmixer.cc 2005-03-13 20:20:31.979547088 +0100
+@@ -15,7 +15,7 @@ ossMixer::ossMixer(void){
+
+ void ossMixer::init(void){
+ char *names[]=SOUND_DEVICE_NAMES;
+- lineinfos = new (LineInfo *)[SOUND_MIXER_NRDEVICES];
++ lineinfos = new LineInfo *[SOUND_MIXER_NRDEVICES];
+ if (-1== (fd = open(mixer_device,O_RDWR))) {
+ std::cout << endl
+ << "Error opening mixer device [" << mixer_device << "]" << endl
diff --git a/media-sound/opmixer/opmixer-0.75.ebuild b/media-sound/opmixer/opmixer-0.75.ebuild
index 3f76ca5f908d..5c7bd6c3d7bc 100644
--- a/media-sound/opmixer/opmixer-0.75.ebuild
+++ b/media-sound/opmixer/opmixer-0.75.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/opmixer/opmixer-0.75.ebuild,v 1.15 2004/09/15 19:39:14 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/opmixer/opmixer-0.75.ebuild,v 1.16 2005/03/13 20:15:58 luckyduck Exp $
+
+inherit eutils
IUSE=""
@@ -12,13 +14,20 @@ SRC_URI="http://optronic.sourceforge.net/files/${MY_P}.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc"
+KEYWORDS="x86 ppc sparc ~amd64"
DEPEND="=x11-libs/gtk+-1.2*
=dev-cpp/gtkmm-1.2*"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc34.patch
+}
+
src_compile() {
- econf || die
+ econf || die "configure failed"
#gcc3.2 fix for #8760
cd ${S}/src
@@ -26,10 +35,10 @@ src_compile() {
sed -e 's/ endl/ std::endl/' \
volset.cc.old > volset.cc
- emake || die
+ emake || die "make failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR=${D} install || die "make install failed"
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
}