summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-04-21 09:01:16 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-04-21 09:01:16 +0000
commit5acd4c1f99ab5c0ae059ddb62b35142aa42f44e8 (patch)
treecfccb07bcddd187f9ff87ea26a16a70f8746cf0b /media-sound/potamus/potamus-0.12.ebuild
parentFix build with new ffmpeg/libav. FIxes bug#409685. (diff)
downloadhistorical-5acd4c1f99ab5c0ae059ddb62b35142aa42f44e8.tar.gz
historical-5acd4c1f99ab5c0ae059ddb62b35142aa42f44e8.tar.bz2
historical-5acd4c1f99ab5c0ae059ddb62b35142aa42f44e8.zip
Fix building with newer libav api. Fixes bug#390821.
Package-Manager: portage-2.2.0_alpha100/cvs/Linux x86_64
Diffstat (limited to 'media-sound/potamus/potamus-0.12.ebuild')
-rw-r--r--media-sound/potamus/potamus-0.12.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/media-sound/potamus/potamus-0.12.ebuild b/media-sound/potamus/potamus-0.12.ebuild
index 048ea12ad0f7..0eac2213e2bc 100644
--- a/media-sound/potamus/potamus-0.12.ebuild
+++ b/media-sound/potamus/potamus-0.12.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/potamus/potamus-0.12.ebuild,v 1.1 2011/04/21 19:36:14 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/potamus/potamus-0.12.ebuild,v 1.2 2012/04/21 09:01:15 scarabeus Exp $
+
+EAPI=4
-EAPI=2
inherit gnome2
DESCRIPTION="a lightweight audio player with a simple interface and an emphasis on high audio quality."
@@ -28,7 +29,14 @@ RDEPEND="x11-libs/gtk+:2
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_prepare() {
+ gnome2_src_prepare
+
+ sed -i -e \
+ 's:CODEC_TYPE_AUDIO:AVMEDIA_TYPE_AUDIO:g' \
+ src/input-avcodec.c || die
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc NEWS README TODO
+ default
}