summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-15 23:26:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-15 23:26:33 +0000
commit82ce0eea086cbd4c6fc4a3f809b160a8ddb85582 (patch)
treed322cf3f8a2b8935188dd4878d7188231f194418 /media-sound/sox/files
parentUpstream fix for building qt4 gui without wxwindows (diff)
downloadhistorical-82ce0eea086cbd4c6fc4a3f809b160a8ddb85582.tar.gz
historical-82ce0eea086cbd4c6fc4a3f809b160a8ddb85582.tar.bz2
historical-82ce0eea086cbd4c6fc4a3f809b160a8ddb85582.zip
Make ogg optional
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'media-sound/sox/files')
-rw-r--r--media-sound/sox/files/sox-13.0.0-oggautomagic.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-sound/sox/files/sox-13.0.0-oggautomagic.patch b/media-sound/sox/files/sox-13.0.0-oggautomagic.patch
new file mode 100644
index 000000000000..2288538849b9
--- /dev/null
+++ b/media-sound/sox/files/sox-13.0.0-oggautomagic.patch
@@ -0,0 +1,24 @@
+Index: sox-13.0.0/configure.ac
+===================================================================
+--- sox-13.0.0.orig/configure.ac
++++ sox-13.0.0/configure.ac
+@@ -120,12 +120,19 @@ AC_SUBST(SNDFILE_CFLAGS)
+ AC_SUBST(SNDFILE_LIBS)
+
+ dnl Check for Ogg Vorbis libraries
++AC_ARG_WITH(oggvorbis, AC_HELP_STRING([--with-oggvorbis],
++ [Use oggvorbis if present (default is yes)]),
++ [with_ogg_vorbis=$withval],
++ [with_ogg_vorbis=yes])
++
++if test "$with_ogg_vorbis" = yes; then
+ AC_CHECK_HEADER(vorbis/codec.h,
+ [with_ogg_vorbis=yes
+ AC_CHECK_LIB(ogg, ogg_packet_clear,, with_ogg_vorbis=no)
+ AC_CHECK_LIB(vorbisfile, ov_clear,, with_ogg_vorbis=no)
+ AC_CHECK_LIB(vorbisenc, vorbis_encode_init_vbr,, with_ogg_vorbis=no)],
+ with_ogg_vorbis=no)
++fi
+
+ dnl Check for FLAC libraries
+ AC_ARG_WITH(flac,