summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-25 12:21:58 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-25 12:21:58 +0000
commit55aa633567bfea403f2e6d191b1cad7481553193 (patch)
tree0fdd36557bf80867355fa67ea1e310d9b83919a9 /media-sound/toolame/toolame-02l-r2.ebuild
parenttrim whitespace (diff)
downloadhistorical-55aa633567bfea403f2e6d191b1cad7481553193.tar.gz
historical-55aa633567bfea403f2e6d191b1cad7481553193.tar.bz2
historical-55aa633567bfea403f2e6d191b1cad7481553193.zip
Add largefile support for glibc/uclibc. Fix ${CC} handling for cross-compile sake.
Package-Manager: portage-2.0.51.22
Diffstat (limited to 'media-sound/toolame/toolame-02l-r2.ebuild')
-rw-r--r--media-sound/toolame/toolame-02l-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/toolame/toolame-02l-r2.ebuild b/media-sound/toolame/toolame-02l-r2.ebuild
new file mode 100644
index 000000000000..2d37a0f749f6
--- /dev/null
+++ b/media-sound/toolame/toolame-02l-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/toolame/toolame-02l-r2.ebuild,v 1.1 2005/08/25 12:21:58 flameeyes Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="tooLAME - an optimized mpeg 1/2 layer 2 audio encoder"
+HOMEPAGE="http://www.planckenergy.com"
+SRC_URI="mirror://sourceforge/toolame/${P}.tgz"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="virtual/libc
+ sys-devel/gcc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-uint.patch
+}
+
+src_compile() {
+ # Enable largefile support, as toolame doesn't use autoconf
+ ( use elibc_glibc || use elibc_uclibc ) && \
+ append-flags "-D_FILE_OFFSET_BITS=64"
+
+ tc-export CC
+
+ emake || die
+}
+
+src_install() {
+ dobin toolame || die
+ dodoc README HISTORY FUTURE html/* text/*
+}
+
+