summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2003-02-14 13:16:32 +0000
committerDan Armak <danarmak@gentoo.org>2003-02-14 13:16:32 +0000
commitff5758f6389ae4b15abed42343a500618dd2c3bb (patch)
treebba2ec038be159a20118b259579b8480aef46b0f /media-sound/zinf
parentAdded -DHPPA for gcc on hppa. Added hppa to keywords. (diff)
downloadhistorical-ff5758f6389ae4b15abed42343a500618dd2c3bb.tar.gz
historical-ff5758f6389ae4b15abed42343a500618dd2c3bb.tar.bz2
historical-ff5758f6389ae4b15abed42343a500618dd2c3bb.zip
add arts support, see #9675
Diffstat (limited to 'media-sound/zinf')
-rw-r--r--media-sound/zinf/ChangeLog9
-rw-r--r--media-sound/zinf/zinf-2.2.3.ebuild27
2 files changed, 26 insertions, 10 deletions
diff --git a/media-sound/zinf/ChangeLog b/media-sound/zinf/ChangeLog
index 05a63f7566c0..76d0a39ea16a 100644
--- a/media-sound/zinf/ChangeLog
+++ b/media-sound/zinf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/zinf
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/ChangeLog,v 1.7 2003/02/12 07:35:46 vapier Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/ChangeLog,v 1.8 2003/02/14 13:16:32 danarmak Exp $
+
+ 14 Feb 2003; Dan Armak <danarmak@gentoo.org> zinf-2.2.3.ebuild:
+
+ Enable arts output support with the makefile fixes needed for it.
+ This resolves bug #9675.
*zinf-2.2.3 (07 Feb 2003)
diff --git a/media-sound/zinf/zinf-2.2.3.ebuild b/media-sound/zinf/zinf-2.2.3.ebuild
index b00c23c4477c..6d2252d85a5c 100644
--- a/media-sound/zinf/zinf-2.2.3.ebuild
+++ b/media-sound/zinf/zinf-2.2.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/zinf-2.2.3.ebuild,v 1.3 2003/02/13 13:22:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/zinf-2.2.3.ebuild,v 1.4 2003/02/14 13:16:32 danarmak Exp $
-IUSE="esd X gtk oggvorbis gnome"
+IUSE="esd X gtk oggvorbis gnome arts"
inherit kde-functions
@@ -21,8 +21,8 @@ RDEPEND="=dev-libs/glib-1.2*
esd? ( media-sound/esound )
gtk? ( >=media-libs/gdk-pixbuf-0.8 )
gnome? ( gnome-base/ORBit )
- oggvorbis? ( media-libs/libvorbis )"
- #arts? ( kde-base/arts ) # doesn't work anymore? see bug #9675
+ oggvorbis? ( media-libs/libvorbis )
+ arts? ( kde-base/arts )" # doesn't work anymore? see bug #9675
#alsa? ( media-libs/alsa-lib ) # it only supports alsa 0.5.x, so support disabled
DEPEND="$RDEPEND x86? ( dev-lang/nasm )
@@ -45,7 +45,7 @@ src_unpack() {
# if [ "`use arts`" ]; then
# cd ${S}/io/arts/src
# cp artspmo.cpp 1
-# sed -e 's:artsc/artsc.h:artsc.h:g' 1 > artspmo.cpp
+# sed -e 's:artsc/artsc.h:artsc.h:g' -e 's:artspmo.h:../include/artspmo.h:g' 1 > artspmo.cpp
# fi
}
@@ -58,12 +58,23 @@ src_compile() {
#use alsa ||
myconf="${myconf} --disable-alsa"
use esd || myconf="${myconf} --disable-esd"
-# use arts && export ARTSCCONFIG="$KDEDIR/bin/artsc-config" && myconf="${myconf} --with-extra-includes=${KDEDIR}/include --enable-arts" || \
- myconf="$myconf --disable-arts"
+
+ if [ -n "`use arts`" ]; then
+ export ARTSCCONFIG="$KDEDIR/bin/artsc-config"
+ myconf="${myconf} --enable-arts"
+ else
+ myconf="$myconf --disable-arts"
+ fi
./configure --prefix=/usr --host=${CHOST} ${myconf} || die
make || die
-# use arts && ( CPATH=${KDEDIR}/include/artsc:${S}/io/arts/include make -f Makefile-plugins plugins/arts.pmo || die )
+
+ if [ -n "`use arts`" ]; then
+ export CPATH="${CPATH}:${KDEDIR}/include/artsc:${S}/io/arts/include"
+ cp Makefile.header 1
+ sed -e "s:ARTS_LIBS =:ARTS_LIBS = -lartsc -L${KDEDIR}/lib:" 1 > Makefile.header
+ make -f Makefile-plugins plugins/arts.pmo || die
+ fi
}