summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-02 09:41:04 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-02 09:41:04 +0000
commitb68602cbd8f6d3892b04023d98f945003387c56c (patch)
treefaf06e076fb4d9d52707edf3f5fe7a9b78c3cc90 /media-sound
parentAdded net-misc/curl dep. Only 3.1.8 seems to need it. Closes bug #46398. (diff)
downloadhistorical-b68602cbd8f6d3892b04023d98f945003387c56c.tar.gz
historical-b68602cbd8f6d3892b04023d98f945003387c56c.tar.bz2
historical-b68602cbd8f6d3892b04023d98f945003387c56c.zip
Removed alsa IUSE. Fixed myconf. Closes bug #46475.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/aumix/ChangeLog5
-rw-r--r--media-sound/aumix/aumix-2.8.ebuild23
2 files changed, 15 insertions, 13 deletions
diff --git a/media-sound/aumix/ChangeLog b/media-sound/aumix/ChangeLog
index aa72257e74c3..593ef2eeea26 100644
--- a/media-sound/aumix/ChangeLog
+++ b/media-sound/aumix/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/aumix
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/ChangeLog,v 1.19 2004/02/23 09:01:25 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/ChangeLog,v 1.20 2004/04/02 09:41:04 eradicator Exp $
+
+ 02 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org> aumix-2.8.ebuild:
+ Removed alsa IUSE. Fixed myconf. Closes bug #46475.
22 Feb 2004; Aron Griffis <agriffis@gentoo.org> aumix-2.8.ebuild:
stable on alpha and ia64
diff --git a/media-sound/aumix/aumix-2.8.ebuild b/media-sound/aumix/aumix-2.8.ebuild
index 20b8fb1e1b5b..c6b9b791d6fe 100644
--- a/media-sound/aumix/aumix-2.8.ebuild
+++ b/media-sound/aumix/aumix-2.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/aumix-2.8.ebuild,v 1.13 2004/02/23 09:01:25 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/aumix-2.8.ebuild,v 1.14 2004/04/02 09:41:04 eradicator Exp $
-IUSE="alsa gtk gtk2 gnome gpm nls"
+IUSE="gtk gtk2 gnome gpm nls"
DESCRIPTION="Aumix volume/mixer control program."
SRC_URI="http://jpj.net/~trevor/aumix/${P}.tar.bz2"
@@ -12,9 +12,9 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 hppa amd64 sparc alpha ia64"
+#alsa support is broken in 2.8 alsa? ( >=media-libs/alsa-lib-0.9.0_rc1 )
DEPEND=">=sys-libs/ncurses-5.2
gpm? ( >=sys-libs/gpm-1.19.3 )
- alsa? ( >=media-libs/alsa-lib-0.9.0_rc1 )
gtk? (
!gtk2? ( =x11-libs/gtk+-1.2* )
gtk2? ( >=x11-libs/gtk+-2.0.0 )
@@ -22,21 +22,20 @@ DEPEND=">=sys-libs/ncurses-5.2
nls? ( sys-devel/gettext )"
src_compile() {
- local myconf
+# `use_with alsa`
+ local myconf=`use_with gpm` `use_enable nls`
if use gtk; then
- use gtk2 \
- && myconf="${myconf} --without-gtk1" \
- || myconf="${myconf} --without-gtk with-gtk1"
+ if use gtk2; then
+ myconf="${myconf} --with-gtk --without-gtk1"
+ else
+ myconf="${myconf} --without-gtk --with-gtk1"
+ fi
else
myconf="${myconf} --without-gtk --without-gtk1";
fi
- use gpm || myconf="${myconf} --without-gpm"
- use nls || myconf="${myconf} --disable-nls"
- use alsa || myconf="${myconf} --without-alsa"
-
- econf ${myconf}
+ econf ${myconf} || die
emake || die "make failed"
}