summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-02 09:28:09 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-02 09:28:09 +0000
commitbd2373e0ab98d7ad039d10a7badf8e6cf34efeed (patch)
tree2aa28a0da113d22da6404df0716936c233f35f69 /media-sound
parentAdd a depend that stops installation if jack-cvs is installed. (diff)
downloadhistorical-bd2373e0ab98d7ad039d10a7badf8e6cf34efeed.tar.gz
historical-bd2373e0ab98d7ad039d10a7badf8e6cf34efeed.tar.bz2
historical-bd2373e0ab98d7ad039d10a7badf8e6cf34efeed.zip
New ebuild for support of ardour-cvs.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/jack-cvs/ChangeLog10
-rw-r--r--media-sound/jack-cvs/files/digest-jack-cvs-0.440
-rw-r--r--media-sound/jack-cvs/jack-cvs-0.44.ebuild48
3 files changed, 58 insertions, 0 deletions
diff --git a/media-sound/jack-cvs/ChangeLog b/media-sound/jack-cvs/ChangeLog
new file mode 100644
index 000000000000..0dc1226e1532
--- /dev/null
+++ b/media-sound/jack-cvs/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/jack-cvs
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jack-cvs/ChangeLog,v 1.1 2003/01/02 09:28:09 raker Exp $
+
+*jack-cvs-0.44 (02 Jan 2003)
+
+ 02 Jan 2003; Nick Hadaway <raker@gentoo.org> jack-cvs-0.44.ebuild,
+ files/digest-jack-cvs-0.44 :
+ New ebuild. Conflicts with jack-audio-connection-kit. As this
+ is a "live" cvs build it will permanently marked unstable.
diff --git a/media-sound/jack-cvs/files/digest-jack-cvs-0.44 b/media-sound/jack-cvs/files/digest-jack-cvs-0.44
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/media-sound/jack-cvs/files/digest-jack-cvs-0.44
diff --git a/media-sound/jack-cvs/jack-cvs-0.44.ebuild b/media-sound/jack-cvs/jack-cvs-0.44.ebuild
new file mode 100644
index 000000000000..348e2eccdfc2
--- /dev/null
+++ b/media-sound/jack-cvs/jack-cvs-0.44.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jack-cvs/jack-cvs-0.44.ebuild,v 1.1 2003/01/02 09:28:09 raker Exp $
+
+IUSE="doc"
+
+inherit cvs
+
+DESCRIPTION="A low-latency audio server - cvs version"
+HOMEPAGE="http://jackit.sourceforge.net/"
+
+ECVS_SERVER="cvs.jackit.sourceforge.net:/cvsroot/jackit"
+ECVS_MODULE="jack"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/ardour"
+
+SRC_URI=""
+
+# libjack is LGPL, the rest is GPL
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="x86"
+
+DEPEND="dev-libs/glib
+ >=media-libs/alsa-lib-0.9.0_rc6
+ >=media-libs/libsndfile-1.0.0
+ >=x11-libs/fltk-1.1.1
+ !media-sound/jack-audio-connection-kit"
+
+S="${WORKDIR}/${PN/-cvs/}"
+
+src_compile() {
+ export LDFLAGS="-L/usr/lib/fltk-1.1"
+ export CPPFLAGS="-I/usr/include/fltk-1.1"
+ sh autogen.sh
+ econf || die "configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+
+pkg_postinst() {
+
+ einfo ""
+ einfo "Remember to re-emerge jack-cvs before re-emerging ardour-cvs"
+ einfo ""
+}